Bug 2711 - Correct fonts not displayed and Netscape crashes on java pages
Correct fonts not displayed and Netscape crashes on java pages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 2495 2651 2740 2753 2795 2887 3522 3552 4260 5022 5123 5156 5320 5442 5559 5620 5932 6058 6073 6513 7727 9578 9813 9953 11099 11128 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-10 13:45 EDT by Jay Turner
Modified: 2015-01-07 18:37 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-12 13:00:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 1999-05-10 13:45:02 EDT
User may find sitations where the correct fonts are not
being displayed, or upon going to a java enabled page with
Netscape, it will immediately crash out.
Comment 1 Jay Turner 1999-05-10 13:46:59 EDT
Recommeded workaround is to run "chkfontpath --list" and verify that
all necessary fonts are listed.  If something is missing, run
"chkfontpath --add PATH-TO-FONT" which will add that font and should
take care of the problem.
Comment 2 Bill Nottingham 1999-05-11 10:16:59 EDT
*** Bug 2651 has been marked as a duplicate of this bug. ***

A fresh workstation install leaves netscape-communicator
that has a bus error when running Java applets.  This does
not happen with an upgrade from 5.2.  Adding compatability
libraries seems to fix it.  The dependencies for the
netscape-common rpm should be fixed.

------- Additional Comments From notting@redhat.com  05/10/99 10:00 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi', and restart
the font server. This should fix the problem.
Comment 3 Bill Nottingham 1999-05-11 10:35:59 EDT
*** Bug 2495 has been marked as a duplicate of this bug. ***

Netscape Crash when i go to a site with java.

If i disable java it works fine.

I  use redhat 6.0

the sites i have tried is :

chat.everyday.se
sydsvenskan.se



------- Additional Comments From notting@redhat.com  05/03/99 11:03 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi',
then restart the font server ('/etc/rc.d/init.d/xfs restart').
Does that solve the problem?

------- Additional Comments From jflythe@skillsoft.com  05/11/99 10:29 -------
I have been having this problem on both of my RH 6.0 systems.
This fixed my problems on both of my systems.
Comment 4 Bill Nottingham 1999-05-11 14:02:59 EDT
*** Bug 2740 has been marked as a duplicate of this bug. ***

here are the events:

i'm using netscape enterprise server on other computers and
using my local computer to administer the servers.  when i
try to start an ssl based server on the remote machine,
netscape pops up a window (java based, i think), and lets me
enter the decryption key password.  i type it, click ok and
all is well.

enter redhat 6.0 stock from the cdrom (using enlightenment).
when i click "start ssl-server", netscape prints "loading
java" in the status bar at the bottom, then crashes.  now,
before we write this off as a netscape bug, i decided to run
netscape 451 from another computer (a sparc 3k w/ solaris
251) and export the DISPLAY to my redhat6 linux box.  i do
the same "start ssl-server" steps, and netscape again
crashes.

when i run the same netscape on the console of the sparc, it
works fine.  same if i run netscape 451 on win98.  it just
appears that the window manager, linux, or gnome is barfing
at netscape wanted to display that child window for the
password.

i'm posting this as a gnome bug, but it could be something
in enlightenment or X or who knows what.
Comment 5 Bill Nottingham 1999-05-12 11:00:59 EDT
*** Bug 2753 has been marked as a duplicate of this bug. ***

I recently upgraded to RH 6.0 on my Micron Millenia PII box.
Netscape has been suffering many many crashes. Any page with
an embedded JAVA applet causes a crash as well as random
other crashes. Crashes are always a result of a "bus error."

I remember this being a problem with an old libc and memory
allocation with Netscape 2.0 (I just remember patching my
system for that)... I don't know if this is similar or not.
I've tried downgrading my netscape packages as well as
reinstalling, with no luck, so it seems that the problem
might be elsewhere...

-nate
nate@jnf.cx
Comment 6 Bill Nottingham 1999-05-13 15:38:59 EDT
*** Bug 2795 has been marked as a duplicate of this bug. ***

When i go to a site with java in it or simply start the java
console, netscape is killed !!
Comment 7 Jeff Johnson 1999-05-16 19:42:59 EDT
*** Bug 2495 has been marked as a duplicate of this bug. ***

Netscape Crash when i go to a site with java.

If i disable java it works fine.

I  use redhat 6.0

the sites i have tried is :

chat.everyday.se
sydsvenskan.se



------- Additional Comments From notting@redhat.com  05/03/99 11:03 -------
run 'chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi',
then restart the font server ('/etc/rc.d/init.d/xfs restart').
Does that solve the problem?

------- Additional Comments From jflythe@skillsoft.com  05/11/99 10:29 -------
I have been having this problem on both of my RH 6.0 systems.
This fixed my problems on both of my systems.

------- Additional Comments From notting@redhat.com  05/11/99 10:35 -------


*** This bug has been marked as a duplicate of 2711 ***
Comment 8 Bill Nottingham 1999-05-17 17:50:59 EDT
*** Bug 2887 has been marked as a duplicate of this bug. ***

When loading the URL http://java.sun.com netscape crashes.

The last lines of strace are:
--- SIGSEGV (Segmentation fault) ---
getpid()                                = 922
kill(922, SIGBUS)                       = 0
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++

And yes, the environment variable CLASSPATH is unset.
Comment 9 bpinaud 1999-05-17 19:08:59 EDT
I have installed Communicator 4.6 (in tar.gz) and set the CLASSPATH,
but now, netscape is not killed but the page is displayed and the
applet is not running like the java console which doesn't work
Comment 10 Bill Nottingham 1999-06-17 10:42:59 EDT
*** Bug 3522 has been marked as a duplicate of this bug. ***

Multiple versions of Netscape (4.08, 4.51, 4.6) crash with a
bus error when navigating to a site with Java applets.  As
soon as the status bar reads "Starting Java", the
application dies.

As reported by Kalle Korpijoki <KKJOKI@my-dejanews.com> (and
probably several others) reported, this problem is solved by
adding the entry:

/usr/X11R6/lib/X11/fonts/75dpi

as the last entry of the "catalogue=" field in
/etc/X11/fs/config.  The font server must be restarted by
typing:

/etc/rc.d/init.d/xfs restart

from an xterm running as root.

Thanks to the folks on Deja.com for finding and posting a
(the?) solution.

-Mike Panzitta
mike@doberman.com
Comment 11 Alan Cox 1999-06-18 10:17:59 EDT
Mike Shaver of netscape has confirmed this is a problem with the sun
jdk code and the font setup. They don't appear to plan to fix i, s the
work around will be needed.
Comment 12 Alan Cox 1999-06-18 10:54:59 EDT
*** This bug has been marked as a duplicate of 2386 ***
Comment 13 Bill Nottingham 1999-06-18 11:23:59 EDT
*** Bug 3552 has been marked as a duplicate of this bug. ***

Loading any page with a java applet causes netscape to
crash.  It happens with communicator downloaded straight
from netscape, as well.  I have a AMD k6-350 on a VIA
motherboard w 64 MB of RAM, 4.5 and 1.6 GB IDE hard drives,
Matrox G200 AGP, SoundBlaster compatible ISA card, and a
56k modem ISA.  I am running kernel 2.2.9, but it did the
same thing with the stock kernel.
Comment 14 Bill Nottingham 1999-07-29 19:31:59 EDT
*** Bug 4260 has been marked as a duplicate of this bug. ***

Netscape package shipped with RH6.0 crashes with a "Bus
Error" whenever someone tries to run any Java applet.

Upgrading to Netscape 4.6 (as per RH errata page) doesn't
seem to help either.  I have also tried to upgrade to kernel
2.2.10, but no help again.
Comment 15 Bill Nottingham 1999-09-09 10:23:59 EDT
*** Bug 5022 has been marked as a duplicate of this bug. ***

This bug has appeared on sparc and x86 for me.

The default install of 6.0 with Netscape, trying to use Java
causes Netscape to die a horrible death (bus error).

It seems that it is croaking in "GetFontList", and by
reconfiguring xfs to look at all the available fonts that
are installed (including the ones in
/var/share/fonts/default) it fixes it. It shouldn't die
getting a list of fonts. I suspect that it tried to get a
list of specific fonts and couldn't get any, and got a NULL
list back, and it croaked becaues it doesn't check for
NULLs. But that is just my suspicion.
Comment 16 Bill Nottingham 1999-09-14 11:10:59 EDT
*** Bug 5123 has been marked as a duplicate of this bug. ***

I am running all updates for rh6.0, I think this problem
appeared after upgrading to XFree86 3.3.5-0.60. netscape
crashes on every web page with a java applet, even on ones
that worked fine before. It prints 'Bus Error' to the
console.
I'm using a custom-compiled 2.2.12 SMP kernel.
Comment 17 Bill Nottingham 1999-09-15 11:13:59 EDT
*** Bug 5156 has been marked as a duplicate of this bug. ***

Hi All,
I am an italian user of Redhat 6.0.
There are some Internet addresses those cause the crashing
of Netscape communicator.
The URL are www.repubblica.it and www.corriere.it; I suppose
there are other like these.
When in the Netscape status bar is displayed "starting
java", it crashes.

Thanking you in andvance I wish you best regards
Comment 18 Bill Nottingham 1999-09-23 09:52:59 EDT
*** Bug 5320 has been marked as a duplicate of this bug. ***

Every time I try to go to a page which contains Java applets
Netscape says "Starting java..." in the status line for a
second, and crashes with the "Bus error" message. I've tried
4.61, 4.6, 4.5, 4.08 libc5 and glibc2.0 versions. All the
same...

e.g.: http://www.wine.org
Comment 19 Bill Nottingham 1999-09-29 16:13:59 EDT
*** Bug 5442 has been marked as a duplicate of this bug. ***

Repeat by:
	Start netscape under RedHat 6.0 as generically
configured (I.E. with the GNOME session manager enabled
by default.)

	Start the Java console from the
		Communicator->Tools->Java Console
	menu.

Netscape dies with a bus error, but does NOT leave a core
dump.

This demonstrates that Netscape dies on ANY page that uses
java.

This occurs with 4.51 as installed in the usual 6.0,
also with 4.6 as distributed in the upgrade RPM,
as well as 4.61 (libc2 version) fetched from Netscape.com,
which RUNS JUST FINE under RedHat 5.2 (and fvwm instead of
enlightenment).

This bus error occurrs both with MOZILLA_HOME unset
(the default) and with MOZILLA_HOME set to
/usr/lib/netscape.

I think this is a RedHat issue more than a Netscape
issue, since the same netscape binaries do work just fine
under 5.2.

Am I getting bit by a libc incompatibility?

I am VERY surprised nobody else has reported so obvious
a bug.  A colleague with a similar machine and config to
mine has ALSO reproduced this problem.

I do not know if this problem affects other platforms
than the i386.

------- Additional Comments From   09/30/99 23:10 -------
In my particular case, "chkfontpath --add ..." was not the fix.
The 75dpi font path was already present.

I noticed on my system that the 100dpi font path was reported by
"chkfontpath --add" but the 100dpi font RPM had not been installed.
My problem was fixed by installing the XFree86-100dpi-fonts package.
Comment 20 Bill Nottingham 1999-10-05 10:29:59 EDT
*** Bug 5559 has been marked as a duplicate of this bug. ***

Every time a page with a Java applet is encountered Netscape
crashes. Happens to both the version shipped with Red Hat
6.0 and to Netscape 4.61

Netscape 4.5 and 4.61 worked fine on the same machine when
it was running Red Hat 5.1

I have installed Red Hat 6.0 on 2 different machines, one an
HP Vectra desktop and one an IBM thinkpad laptop, and
encounterd the same problem on both machines.
Comment 21 Bill Nottingham 1999-10-06 11:04:59 EDT
*** Bug 5620 has been marked as a duplicate of this bug. ***

when i go to some web sites netscape logs off to a desktop
screen.
I have 6.0 runing as a web server, but apache is not yet up

It is as if I am missing something, i get no messages,
netscape just disappears
Comment 22 Bill Nottingham 1999-10-14 10:16:59 EDT
*** Bug 5932 has been marked as a duplicate of this bug. ***

Whenever I move to a  website  with a complicated java
script, Netscape simply exits/disappears.  If I try to run
from Netscapes pull  down window "Communicator/Tools/Java
Console"     it also  exits/disappears.  During Netscape
startup, the /var/log/messages file contains the  line
entries "cannot locate module ppp-compress-21, -26, and
-24.  I've already gone to a mirror  web  site, downloaded
and installed netscape-common-4.7-1.i386.rpm,
netscape-communicator-4.7-1.i386.rpm, and
netscape-navigator-4.7-1.i386.rpm.  The exit/disappearing
act hasn't been corrected.  I am able to restart Netscape
and   get back onto  Internet, but to stay up and  running,
I must stay away from complex Java  screens.  What's else
can  I do to correct this problem.  I  purchaased  Redhat
6.0  early this  summer.
Comment 23 Bill Nottingham 1999-10-18 12:41:59 EDT
*** Bug 6058 has been marked as a duplicate of this bug. ***

after upgrading to netscape 4.7 netscape doesn't work.  The
only error that I get is  --> bus error
Comment 24 Bill Nottingham 1999-10-18 22:00:59 EDT
*** Bug 6073 has been marked as a duplicate of this bug. ***

When I access a site that starts a Java app, Netscape
immediately shuts down completely.  Happens everytime.
Running Gnome with Netscape that came with 6.0 release.

????

Bryan
Comment 25 Bill Nottingham 1999-10-29 17:25:59 EDT
*** Bug 6513 has been marked as a duplicate of this bug. ***

I have reported before that netscape disappears on some we
sites when running gnome..>netscape from the console of
redhat 6.0

I found out that I am getting a bus error.

Please tell me what to do to diag. this problem.
it only occurs in netscape and only on some web pages with
banner ads that have motion.
I uploaded 4.7 but no change occurred.
Comment 26 Bill Nottingham 1999-12-10 11:16:59 EST
*** Bug 7727 has been marked as a duplicate of this bug. ***
Comment 27 Bill Nottingham 2000-02-21 11:12:59 EST
*** Bug 9578 has been marked as a duplicate of this bug. ***
Comment 28 Bill Nottingham 2000-02-21 11:13:59 EST
*** Bug 9578 has been marked as a duplicate of this bug. ***
Comment 29 Bill Nottingham 2000-02-28 10:50:59 EST
*** Bug 9813 has been marked as a duplicate of this bug. ***
Comment 30 Bill Nottingham 2000-03-04 13:00:59 EST
*** Bug 9953 has been marked as a duplicate of this bug. ***
Comment 31 Bill Nottingham 2000-04-28 16:32:59 EDT
*** Bug 11099 has been marked as a duplicate of this bug. ***
Comment 32 Bill Nottingham 2000-05-02 13:01:59 EDT
*** Bug 11128 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.