Bug 111320 - XFree86 update breaks Xinerama on Radeon 7500
XFree86 update breaks Xinerama on Radeon 7500
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 20:07 EST by Andrew Rechenberg
Modified: 2007-03-27 00:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 05:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log (42.35 KB, text/plain)
2003-12-01 20:08 EST, Andrew Rechenberg
no flags Details
XF86 config file modified from redhat-config-xfree86 generated one (4.03 KB, text/plain)
2003-12-01 20:09 EST, Andrew Rechenberg
no flags Details

  None (edit)
Description Andrew Rechenberg 2003-12-01 20:07:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20031119 Galeon/1.3.7

Description of problem:
Before updating XFree86 today I had an ATI Radeon VE dual head card
working with xinerama (independent displays).  I had an
XFree86-4.3.0-2 RPM built from an SRPM patched with the patch I
attached in bug 88748

After updating to XFree86-4.3.0-2.90.43, the same XF86Config file now
does not work with xinerama.  The same thing is displayed on both
monitors simultaneously.

I have tried starting from scratch using redhat-config-xfree86 to
create a fresh XF86Config file and editing it to make xinerama work
and it does not.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2.90.43

How reproducible:
Always

Steps to Reproduce:
1. Patch XFree86-4.3.0-2 SRPM with patch from bug 88748 and rebuild
2. rpm -ivh XFree86-4.3.0-2 RPM from step 1
3. Use attached XF86Config file
4. Watch Xinerama work.
5. Update to curren XFree86 errata 
6. Watch Xinerama break
    

Actual Results:  No Xinerama

Expected Results:  Two independent displays 

Additional info:
Comment 1 Andrew Rechenberg 2003-12-01 20:08:20 EST
Created attachment 96272 [details]
XFree86 log
Comment 2 Andrew Rechenberg 2003-12-01 20:09:58 EST
Created attachment 96273 [details]
XF86 config file modified from redhat-config-xfree86 generated one
Comment 3 Mike A. Harris 2003-12-02 05:33:27 EST
The Radeon driver changed not long after Red Hat Linux 9 was released,
in order to provide more support for more hardware (and newer
hardware).  With the new support, the configuration of the driver
has changed for some users, in particular multi-head users.  This
was observed in rawhide, during the development of Fedora Core 1
about a month or so after RHL 9 was released.

If you are using Xinerama, and it is no longer working, you need to
read the "radeon" manpage, and look at the Monitorlayout option.
You may or may not need to use that option in order to get Xinerama
to work, and you may have to experiment with different settings
to get it to work the way you want with your particular hardware.

This is the way the new Radeon driver works, and will work also in
XFree86 4.4.0 and for the forseeable future, unless the upstream
maintainers make further changes.  As such, this is not a bug, but
an intentional change by the upstream driver maintainers, of how the
driver works and must be configured.

If you have further difficulties, or are unable to determine the
right configuration options that work with your setup, you can
contact the xfree86@xfree86.org mailing list for technical support
assistance.

Comment 4 Mike A. Harris 2003-12-02 05:34:00 EST
Closing bug NOTABUG due to configuration related issue.

Note You need to log in before you can comment on or make changes to this bug.