Bug 1113439 - Warning: Apostrophes (') in source does not match number in translation
Summary: Warning: Apostrophes (') in source does not match number in translation
Status: CLOSED DUPLICATE of bug 872039
Alias: None
Product: Zanata
Classification: Retired
Component: Usability
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-26 08:20 UTC by Rajesh Ranjan
Modified: 2015-04-21 04:33 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-03 00:47:39 UTC


Attachments (Terms of Use)

Description Rajesh Ranjan 2014-06-26 08:20:18 UTC
Description of problem:

While Translating "script expression ''{0}'' didn't evaluate to true", I found that tool takes Apostrophe of the word "didn't" also into account. And so reflecting it as warning. I think tool should be able to differentiate between phrase like ''{0}'' and didn't.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ding-Yi Chen 2014-07-03 00:47:39 UTC
As explained in https://bugzilla.redhat.com/show_bug.cgi?id=856019#c3, the correct way to handle apostrophes is double it. 

i.e. use didn''t in stead of didn't.

*** This bug has been marked as a duplicate of bug 872039 ***


Note You need to log in before you can comment on or make changes to this bug.