Bug 1113882 - [ ERROR ] Failed to execute stage 'Closing up': [ERROR]::oVirt sdk is disconnected from the server.
Summary: [ ERROR ] Failed to execute stage 'Closing up': [ERROR]::oVirt sdk is disconn...
Keywords:
Status: CLOSED DUPLICATE of bug 1116009
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On: 1116009
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-06-27 06:53 UTC by Sandro Bonazzola
Modified: 2014-08-12 14:55 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.5.0-beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 14:01:36 UTC
oVirt Team: ---


Attachments (Terms of Use)
setup logs (230.70 KB, application/x-gzip)
2014-06-27 06:53 UTC, Sandro Bonazzola
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29348 None None None Never

Description Sandro Bonazzola 2014-06-27 06:53:01 UTC
Created attachment 912686 [details]
setup logs

While installing candidate 3.5.0 beta All In One on F19 I got the error in Summary and the following Traceback in the logs:

2014-06-27 08:34:09 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/all-in-one/vdsm.py", line 196, in _closeup
    engine_api = self._waitEngineUp()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/all-in-one/vdsm.py", line 128, in _waitEngineUp
    insecure=True,
  File "/usr/lib/python2.7/site-packages/ovirtsdk/api.py", line 97, in __init__
    self.disconnect()
  File "/usr/lib/python2.7/site-packages/ovirtsdk/api.py", line 227, in disconnect
    raise DisconnectedError
DisconnectedError: [ERROR]::oVirt sdk is disconnected from the server.

Error may be caused by sdk or engine, need to be investigated.

Comment 1 Simone Tiraboschi 2014-07-01 13:42:57 UTC
After a further investigation I found that patch 29348 just hides the problem without really solving it.


Inspecting apache log I found that:
127.0.0.1 - - [01/Jul/2014:10:50:23 +0200] "GET /ovirt-engine/api HTTP/1.1" 503 299
127.0.0.1 - - [01/Jul/2014:10:50:28 +0200] "GET /ovirt-engine/api HTTP/1.1" 404 -

first attempt gives a 503, seconds a 404


while in httpd/ssl_error_log I found that:
[Tue Jul 01 10:50:23.777938 2014] [proxy:error] [pid 18689] (111)Connection refused: AH00957: AJP: attempt to connect to 127.0.0.1:8702 (127.0.0.1) failed
[Tue Jul 01 10:50:23.777979 2014] [proxy:error] [pid 18689] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 5s
[Tue Jul 01 10:50:23.777987 2014] [proxy_ajp:error] [pid 18689] [client 127.0.0.1:54394] AH00896: failed to make connection to backend: 127.0.0.1

so it seams that in some case a requests to apache when jboss is still not fully started causes AJP to disable for 5 sec.
A second request within five seconds than gets a 404 that generates a different exception and so the bug.

Comment 2 Simone Tiraboschi 2014-07-08 13:46:09 UTC
The resolution of 
https://bugzilla.redhat.com/1116009
closes also this one.

Comment 3 Simone Tiraboschi 2014-07-08 14:01:36 UTC

*** This bug has been marked as a duplicate of bug 1116009 ***


Note You need to log in before you can comment on or make changes to this bug.