Bug 1113891 - storage domains are listed twice when filtering by host
Summary: storage domains are listed twice when filtering by host
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Daniel Erez
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard: storage
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-06-27 07:09 UTC by Sandro Bonazzola
Modified: 2016-02-10 17:10 UTC (History)
11 users (show)

Fixed In Version: ovirt-engine-3.5.0_beta
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:51 UTC
oVirt Team: Storage


Attachments (Terms of Use)
screenshot (144.33 KB, image/png)
2014-06-27 07:09 UTC, Sandro Bonazzola
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29365 master MERGED core: fix search of SDs when filtered by host Never

Description Sandro Bonazzola 2014-06-27 07:09:04 UTC
Created attachment 912693 [details]
screenshot

Added storage to an host, looking at storage tab, storage are listed twice.
Attaching screenshot.

Comment 1 Nir Soffer 2014-06-27 11:18:57 UTC
Daniel, do you want to take a look at this?

Comment 2 Daniel Erez 2014-06-28 12:45:35 UTC
It seems that the issue has been caused due to a change in the search mechanism
(change-id: I862873171c6753f8c8863c10c336e981e39dc8cb), hence moving component to 'ovirt-engine-core'.

Since the regression is limited to only a specific search (filtering storage domains by host), moving severity to 'high'.

Comment 3 Kevin Alon Goldblatt 2014-07-07 13:57:56 UTC
Only one instance of each host is displayed in the tree now. Moving to Verified!

Comment 4 Sandro Bonazzola 2014-10-17 12:40:51 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.