Bug 1114057 - uploaded iso is not visible in the engine
Summary: uploaded iso is not visible in the engine
Keywords:
Status: CLOSED DUPLICATE of bug 1114499
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Maor
QA Contact: Gil Klein
URL:
Whiteboard: infra
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-06-27 14:51 UTC by Sandro Bonazzola
Modified: 2016-02-10 19:35 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-11 08:16:38 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Sandro Bonazzola 2014-06-27 14:51:19 UTC
I've installed 
ovirt-engine-3.5.0-0.0.master.20140627080820.gitf7ac3d9.fc19.noarch
added one host, added data and iso domain, copied an iso image inside the iso directory:

# ll /var/lib/exports/iso-20140627140830/239736e3-4d49-4fb1-bd5a-ebef1473c435/images/11111111-1111-1111-1111-111111111111/f19.iso 
-rw-r-----. 1 vdsm kvm 4444913664 16 mag 15.29 /var/lib/exports/iso-20140627140830/239736e3-4d49-4fb1-bd5a-ebef1473c435/images/11111111-1111-1111-1111-111111111111/f19.iso

and pressed the refresh icon in the ui.
In 3.4 the iso showed up, in 3.5 it doesn't show up anymore and can't be used for booting a vm.

Comment 1 Allon Mureinik 2014-07-09 14:57:14 UTC
Maor, any news on this?

Comment 2 Maor 2014-07-09 15:11:05 UTC
It looks like a permission issue, 
Sandro can you please attach the logs of engine and VDSM?
If you do chmod 755 on the files does it show anything new?

Comment 3 Maor 2014-07-09 15:26:17 UTC
I tried to reproduce it, and it seems that the origin of the bug is at the VDSM.
I get the following error:

Thread-916::ERROR::2014-07-09 18:25:15,382::dispatcher::79::Storage.Dispatcher::(wrapper) '_IOProcessFileUtils' object
 has no attribute 'validateQemuReadable'
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/dispatcher.py", line 71, in wrapper
    result = ctask.prepare(func, *args, **kwargs)
  File "/usr/share/vdsm/storage/task.py", line 103, in wrapper
    return m(self, *a, **kw)
  File "/usr/share/vdsm/storage/task.py", line 1179, in prepare
    raise self.error
AttributeError: '_IOProcessFileUtils' object has no attribute 'validateQemuReadable'

Comment 4 Maor 2014-07-09 15:39:57 UTC
It looks like commit 981aad75054c30847b0b6291a7a29733dfe60d07 has already solved this, verifying it...

Comment 5 Maor 2014-07-09 16:11:29 UTC
(In reply to Maor from comment #4)
> It looks like commit 981aad75054c30847b0b6291a7a29733dfe60d07 has already
> solved this, verifying it...

verified succeeded, moving to modify

Comment 6 Sven Kieske 2014-07-10 09:10:33 UTC
See my bug report regarding this wrong file system rights on ISO-Domains:
https://bugzilla.redhat.com/show_bug.cgi?id=1073434

I still think this should work without 755 file rights on the isos, this
is not necessary and a potential candidate for security hardening as you
might have isos which contain sensitive information and shouldn't be world
readable.

This bug was opened some months ago, and I think this can be fixed
really easy..

Comment 7 Sandro Bonazzola 2014-07-11 08:16:38 UTC
Sven bug #1073434 looks like a different issue, related to NFS root squashing.
This is a vdsm bug that should have been fixed with http://gerrit.ovirt.org/29398

*** This bug has been marked as a duplicate of bug 1114499 ***


Note You need to log in before you can comment on or make changes to this bug.