Bug 1114149 - ose-upgrade begin step will never complete when using RHN
Summary: ose-upgrade begin step will never complete when using RHN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 2.0.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks: 1117048 1117997 1126051
TreeView+ depends on / blocked
 
Reported: 2014-06-27 21:57 UTC by Timothy Williams
Modified: 2018-12-06 17:04 UTC (History)
9 users (show)

Fixed In Version: openshift-enterprise-upgrade-2.0.7-1.el6op
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1117048 1117997 1126051 (view as bug list)
Environment:
Last Closed: 2014-08-26 13:51:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1097 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.0.7 bug fix update 2014-08-26 17:51:25 UTC

Description Timothy Williams 2014-06-27 21:57:30 UTC
Description of problem:
When upgrading a 2.0 system to 2.1 that has been registered with RHN, the upgrade step 'begin' will never succeed.

In the begin step, it first checks to ensure the 2.0 channels are enabled, then proceeds to enable the 2.1 channels. However, it cannot enable the 2.1 channel itself and requires manual intervention. After the 2.1 channels are enabled manually and the 2.0 channels disabled, the ose-upgrade begin step then fails because the 2.0 channels are disabled.

Version-Release number of selected component (if applicable):
2.0

How reproducible:
Always

Steps to Reproduce:
1. Install a 2.0 system with RHN
2. Being the upgrade process by `yum updating`, then running `ose-upgrade begin`
3.

Actual results:
Will complain that 2.1 repos need to be enabled manually. After enabling and running the step again, it complains that the 2.0 repositories are not enabled

Expected results:
Enables 2.1 repositories itself, or at least does not fail the check after the 2.1 repositories are enabled.

Additional info:

Comment 5 Ma xiaoqiang 2014-07-10 08:44:15 UTC
Install the Openshift according to the pad, then run the following three scenarios.

Scenario 1. run the 'ose-upgrade begin' without $RHN_USER or $RHN_PASSWD
Output:
<--snip-->
ERROR: run_script
/usr/lib/ruby/site_ruby/1.8/ose-upgrade/host/upgrades/3/rhn/02-new-channels had errors:
--BEGIN OUTPUT--
$RHN_USER and $RHN_PASS must be defined
--END /usr/lib/ruby/site_ruby/1.8/ose-upgrade/host/upgrades/3/rhn/02-new-channels OUTPUT--
INFO: Setting host step 'begin' status to FAILED


Scenario 2. run the 'ose-upgrade begin' with wrong $RHN_USER or $RHN_PASSWD
Output:
<--snip-->
Error Message:
    Invalid username/password combination
Error Class Code: 2
Error Class Info: 
     Invalid username and password combination.
     If you are using email address as a login, try using your associated
     login name instead.
<--snip-->


Scenario 3. run the 'ose-upgrade begin' with correct $RHN_USER and $RHN_PASSWD
Output:
<--snip-->
INFO: Setting host step 'begin' status to COMPLETE
INFO: To continue the upgrade, install a specific upgrade package.
WARN: determine_upgrade_status
You appear to have an OpenShift Enterprise broker installed;
please install the broker upgrade package to proceed with this upgrade.
  # yum install openshift-enterprise-upgrade-broker

Comment 7 errata-xmlrpc 2014-08-26 13:51:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1097.html


Note You need to log in before you can comment on or make changes to this bug.