Bug 1117048 - ose-upgrade begin step will never complete when using RHN
Summary: ose-upgrade begin step will never complete when using RHN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 1.2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: libra bugs
URL:
Whiteboard:
: 1126051 (view as bug list)
Depends On: 1114149 1117997 1126051
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-07 21:25 UTC by Jason DeTiberus
Modified: 2018-12-06 17:12 UTC (History)
11 users (show)

Fixed In Version: openshift-enterprise-upgrade-1.2.9-2.el6op
Doc Type: Bug Fix
Doc Text:
Clone Of: 1114149
Environment:
Last Closed: 2014-08-26 13:52:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1096 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 1.2.9 bug fix update 2014-08-26 17:51:30 UTC

Comment 4 Ma xiaoqiang 2014-07-10 08:44:02 UTC
Install the Openshift according to the pad, then run the following three scenarios.

Scenario 1. run the 'ose-upgrade begin' without $RHN_USER or $RHN_PASSWD
Output:
<--snip-->
ERROR: run_script
/usr/lib/ruby/site_ruby/1.8/ose-upgrade/host/upgrades/2/rhn/02-new-channels had errors:
--BEGIN OUTPUT--
$RHN_USER and $RHN_PASS must be defined
--END /usr/lib/ruby/site_ruby/1.8/ose-upgrade/host/upgrades/2/rhn/02-new-channels OUTPUT--
INFO: Setting host step 'begin' status to FAILED


Scenario 2. run the 'ose-upgrade begin' with wrong $RHN_USER or $RHN_PASSWD
Output:
<--snip-->
Error Message:
    Invalid username/password combination
Error Class Code: 2
Error Class Info: 
     Invalid username and password combination.
     If you are using email address as a login, try using your associated
     login name instead.
<--snip-->


Scenario 3. run the 'ose-upgrade begin' with correct $RHN_USER and $RHN_PASSWD
Output:
<--snip-->
--END /usr/lib/ruby/site_ruby/1.8/ose-upgrade/host/upgrades/2/rhn/03-configure-yum-priorities OUTPUT--
INFO: updating /etc/openshift-enterprise-release
INFO: Setting host step 'begin' status to COMPLETE
INFO: To continue the upgrade, install a specific upgrade package.
WARN: determine_upgrade_status
You appear to have an OpenShift Enterprise broker installed;
please install the broker upgrade package to proceed with this upgrade.
  # yum install openshift-enterprise-upgrade-broker

Comment 5 Jason DeTiberus 2014-08-04 13:52:26 UTC
*** Bug 1126051 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2014-08-26 13:52:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1096.html


Note You need to log in before you can comment on or make changes to this bug.