Bug 111484 - if locale is not en_US resume fails to restart networking
if locale is not en_US resume fails to restart networking
Status: CLOSED DUPLICATE of bug 110420
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 07:14 EST by Giuliano Colla
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuliano Colla 2003-12-04 07:14:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.5) Gecko/20031007

Description of problem:
symptom: after a suspend, resume fails to restore networking (and
possibly other services) if the system locale is set to something
different from C or en_US.

cause: apmscript sets LANG and LC_ALL in order to parse service status
information getting rid of i18, while bash uses LC_MESSAGES to
determine the message translation locale.

suggested remedy: replace all occurences of LC_ALL with LC_MESSAGES in
/etc/sysconfig/apm-scripts/apmscript

Version-Release number of selected component (if applicable):
3.0.2-18

How reproducible:
Always

Steps to Reproduce:

1. on a laptop with apm support enabled, set system locale to it_IT or
fr_FR, or whatever non en_US
2. run apm -suspend, or cause a suspend by closing laptop lid
3. cause a resume (with the resume button, or whatever the laptop BIOS
uses for that purpose)
    

Actual Results:  run ifconfig and verify that no device is shown (not
even lo)

a "service network restart" is required to restore networking as it
was before suspend.

Expected Results:  networking at resume should be the same that was at
suspend

Additional info:

if either system locale is set to en_US, or all the occurences of
LC_ALL in /etc/sysconfig/apm-scripts/apmscript are replaced with
LC_MESSAGES, the services which were active at suspend, are properly
restored at resume.
Comment 1 Miloslav Trmac 2003-12-04 10:04:08 EST
The explanation doesn't make sense to me,
/etc/sysconfig/apm-scripts/apmscript does not use the bash string
translation feature ($"...") at all; moreover, the $"..." feature
correctly uses LC_ALL in precedence over LC_MESSAGES.
Comment 2 Bill Nottingham 2003-12-04 11:46:53 EST
This is fixed in the FC1 apmd, as far as I know.

*** This bug has been marked as a duplicate of 110420 ***
Comment 3 Giuliano Colla 2003-12-04 16:30:51 EST
For sake of precision. apmscript doesn't use the bash string
translation fueature, but the commands it invokes do. And, as clearly
stated in bash man page, LC_ALL takes precedence over a lot of LC_ect,
*but not* over LC_MESSAGES. Maybe it's more a bash bug then an
apmscript bug.
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.