Bug 1114914 - engine-setup: cannot import name database
Summary: engine-setup: cannot import name database
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1073943 1115569
TreeView+ depends on / blocked
 
Reported: 2014-07-01 09:17 UTC by movciari
Modified: 2014-08-13 08:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 16:19:20 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description movciari 2014-07-01 09:17:16 UTC
Description of problem:
when trying to upgrade from version
ovirt-engine-setup-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
to version
ovirt-engine-setup-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
when calling engine-setup i get:
# engine-setup 
***L:ERROR Internal error: cannot import name database

# rpm -qa|grep ovirt
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-iso-uploader-3.5.0-0.0.master.20140626.gite89dcdf.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-reports-3.5.0-1.el6.noarch
ovirt-host-deploy-1.3.0-0.0.master.20140629072144.gitdc1f589.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-engine-tools-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-reports-setup-3.5.0-1.el6.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-image-uploader-3.5.0-0.0.master.20140627.gitf19446b.el6.noarch
ovirt-engine-sdk-python-3.5.0.0-1.20140605.git1267422.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-dwh-setup-3.5.0-1.el6.noarch
ovirt-engine-lib-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-userportal-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-backend-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch
ovirt-engine-dwh-3.5.0-1.el6.noarch
ovirt-host-deploy-java-1.3.0-0.0.master.20140629072144.gitdc1f589.el6.noarch
ovirt-engine-cli-3.5.0.0-1.20140605.gita11d080.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch
ovirt-log-collector-3.5.0-0.0.master.20140626.git4cb8c7c.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarc



Version-Release number of selected component (if applicable):


How reproducible:
always on my setup

Steps to Reproduce:
1. install ovirt using ovirt-engine-setup-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch on RHEL6.5
2. yum update
3. engine-setup

Actual results:
***L:ERROR Internal error: cannot import name database

Expected results:
should upgrade ovirt to new version

Additional info:

Comment 1 Jorge Ortega 2014-07-07 17:34:02 UTC
it also breaks engine-cleanup

problem seems to be on ovirt-engine-reports and/or ovirt-engine-dwh

yum remove ovirt-engine-reports* ovirt-engine-dwh*

seems to bring things back up

Comment 2 Simone Tiraboschi 2014-07-16 15:00:56 UTC
It seams that om your case ovirt-engine-dwh ovirt-engine-reports are from a different build set. Did you explicitly excluded them from the upgrade or something similar?

Comment 3 Simone Tiraboschi 2014-07-16 16:19:20 UTC
I've found it: it's a repo problem and not a bug.

Under
http://resources.ovirt.org/pub/ovirt-3.5-pre/rpm/el6/noarch/
now you have: 
1. ovirt-engine-dwh-setup-3.5.0-0.0.master.20140624220907.gitbfb29f0.el6.noarch.rpm
2. ovirt-engine-dwh-setup-3.5.0-1.el6.noarch.rpm

1 is dated 2014/07/01, 2. is dated 2014/06/06.

So the latest correct release for 3.5 beta is 1. but the system chooses 2. cause it's labeled 3.5.0-1 instead of 3.5.0-0.0 as 1.

It already works correctly if you force the installation of the correct release.

Comment 4 Pavel Stehlik 2014-08-13 08:50:56 UTC
Not user issue, thus, can't be NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.