Bug 1114987 - Cannot start VM | The host did not satisfy internal filter Network because network(s) are missing. [NEEDINFO]
Summary: Cannot start VM | The host did not satisfy internal filter Network because ne...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Ondřej Svoboda
QA Contact: Michael Burman
URL:
Whiteboard: network
Depends On: 1122475
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-07-01 11:40 UTC by Meni Yakove
Modified: 2016-02-10 19:36 UTC (History)
14 users (show)

Fixed In Version: v4.16.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:30:42 UTC
oVirt Team: Network
lvernia: needinfo? (msivak)


Attachments (Terms of Use)
engine log (222.87 KB, text/x-log)
2014-07-01 11:40 UTC, Meni Yakove
no flags Details
engine_debug.log (249.71 KB, application/zip)
2014-07-10 14:47 UTC, Meni Yakove
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29790 master MERGED engine: Improve reporting when scheduling fails on network Never
oVirt gerrit 35499 ovirt-engine-3.5 ABANDONED engine: Improve reporting when scheduling fails on network Never

Description Meni Yakove 2014-07-01 11:40:25 UTC
Created attachment 913728 [details]
engine log

Description of problem:
Fail to start VM with error:
The host orange-vdsd.qa.lab.tlv.redhat.com did not satisfy internal filter Network because network(s) are missing.
Same even if the VM has no network


Create empty cluster policy solve the issue


Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch

How reproducible:


Steps to Reproduce:
1. Create new VM
2. Start the VM
3.


Additional info:

2014-07-01 06:36:25,942 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (ajp--127.0.0.1-8702-1) [1c97ffe2] CanDoAction of action RunVm failed. Reasons:VAR__ACTION__RUN,VAR__TYPE__VM,SCHEDULING_ALL_HOSTS_FILTERED_OUT,VAR__FILTERTYPE__INTERNAL,$hostName orange-vdsd.qa.lab.tlv.redhat.com,$filterName Network,$networkNames ,VAR__DETAIL__NETWORK_MISSING,SCHEDULING_HOST_FILTERED_REASON_WITH_DETAIL

Comment 1 Meni Yakove 2014-07-01 13:18:54 UTC
It seems that VM fail to start only on AMD cluster with AMD host

Comment 2 Lior Vernia 2014-07-03 20:54:21 UTC
Sounds related to cluster scheduling policy rather than network.

Comment 3 Meni Yakove 2014-07-06 06:40:21 UTC
Also happened on Intel cluster when tried to migrate VM.

Comment 4 Martin Sivák 2014-07-09 15:29:52 UTC
I can start Vms in my engine, is there anything specific about your display network configuration?

Can you reproduce this with DEBUG level enabled for org.ovirt.engine.core.bll.scheduling.policyunits.NetworkPolicyUnit ?

Comment 5 Meni Yakove 2014-07-10 14:46:28 UTC
Display network is on ovirtmgmt (default).
engine with debug log attached.

Comment 6 Meni Yakove 2014-07-10 14:47:20 UTC
Created attachment 917122 [details]
engine_debug.log

Comment 7 Kobi 2014-07-23 09:11:57 UTC
The issue was a configuration problem, for the network filter to allow a host, the host must have an interface with boot protocol.

The boot protocol for that host was set to "none".

Once changing the boot protocol there was no problem running a VM.

Comment 8 Martin Sivák 2014-07-23 09:24:41 UTC
The referenced patch improves the reporting.

Comment 9 Lior Vernia 2014-07-23 12:07:55 UTC
This is apparently caused due to Bug 1122475, leaving open for QE verification after that is fixed. Marking it as blocker since it doesn't allow running VMs while DHCP is configured.

Comment 10 Lior Vernia 2014-07-30 08:35:27 UTC
Putting ON_QA as blocking vdsm bug is already VERIFIED. Martin, would you like to use this bug to also backport the logging change?

Comment 11 Michael Burman 2014-08-03 05:44:53 UTC
Verified on-  oVirt Engine Version: 3.5.0-0.0.master.20140722232058.git8e1babc.el6

Comment 12 Sandro Bonazzola 2014-10-17 12:30:42 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.