Bug 1114994 - Cannot edit cluster after upgrade from version 3.4 to 3.5 because cpu type (Intel Haswell) does not match
Summary: Cannot edit cluster after upgrade from version 3.4 to 3.5 because cpu type (I...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Mooli Tayer
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks: 1073943
TreeView+ depends on / blocked
 
Reported: 2014-07-01 12:05 UTC by Nir Soffer
Modified: 2016-02-10 19:35 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.5.0-beta1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:41:44 UTC
oVirt Team: Infra


Attachments (Terms of Use)
edit cluster dialog showing current cpu type and empty cpu type menu (53.87 KB, image/png)
2014-07-01 12:06 UTC, Nir Soffer
no flags Details
engine log while trying to upgrade cluster (375.53 KB, application/x-xz)
2014-07-01 12:29 UTC, Nir Soffer
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 29784 master MERGED upgrade: update vds cpu name of existing hosts to new name. Never
oVirt gerrit 30014 ovirt-engine-3.5 MERGED upgrade: update vds cpu name of existing hosts to new name. Never

Description Nir Soffer 2014-07-01 12:05:04 UTC
Description of problem:

After upgrading engine and vdsm to version 3.5, editing cluster fail because cpu type does not match.

In the clusters tab, cpu type is displayed as: "Intel Haswell"
In the edit cluster menu, it is displayed as: "Intel Haswell Family"

When you open the edit cluster dialog, the cpu type becomes empty,
although it is displayed in the cluster tab.

Any change in the edit cluster dialog cannot be saved, becuase the 
cpu type is not sepcified.

Trying to select "Intel Haswell Family" and save fail with this error:

    Cannot update Cluster and change CPU Cluster name if there are 
    hosts or virtual machines in the Cluster. This CPU name is 
    incompatible with all other available CPUs

Removing both RHEL 6.5 hosts from the cluster did not change
anything.

Removing all virtual machines from the cluster did not change
anything.

Version-Release number of selected component (if applicable):
3.5.0-0.0.master.20140630172346.git994996b.fc19

How reproducible:
Happened once.

Comment 1 Nir Soffer 2014-07-01 12:06:24 UTC
Created attachment 913735 [details]
edit cluster dialog showing current cpu type and empty cpu type menu

Comment 2 Nir Soffer 2014-07-01 12:24:18 UTC
According to Eli, this is related to this:

commit 25b963a31619a1471ecd8fd121cfef7c4b1a5043
Author: Amador Pahim <apahim@redhat.com>
Date:   Fri Mar 21 11:21:15 2014 -0300

    core: Fix listing name for Intel Haswell
    
    All Intel models are listed as "Intel <Model> Family", except for Haswell,
    wich does no contain "Family" in its listing name. Fixing.
    
    Change-Id: I8a8fd8e270bb23200f0d25f00afa8f7108a0f0a0
    Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=1079420
    Signed-off-by: Amador Pahim <apahim@redhat.com>

Comment 3 Nir Soffer 2014-07-01 12:29:25 UTC
Created attachment 913739 [details]
engine log while trying to upgrade cluster

Comment 4 Nir Soffer 2014-07-01 12:41:59 UTC
Correction - removing all hosts and all virtual machines solved the issue. Previously I removed all host, then added one back to remove the virtual machines.

However this still means that a user cannot upgrade becasue the whole point in upgrading is not removing anything :-)

Comment 5 Jiri Belka 2014-08-07 12:16:10 UTC
ok, ovirt-engine-backend-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

I can create CL with Intel Haswell Family without problem (although we don't have a host to add into such CL).

Comment 6 Sandro Bonazzola 2014-10-17 12:41:44 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.