This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 111501 - autologin does not work without manual intervention
autologin does not work without manual intervention
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 108971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 12:32 EST by Brent Fox
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 12:12:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2003-12-04 12:32:59 EST
When enabling the autologin feature in the KDE Control Center (under
System Administration->Login Manager), it appears that autologin
should work on the next reboot.  

However, GDM is the default login manager and does not recognize KDE's
autologin feature.  The user has to manually add a line to
/etc/sysconfig/desktop that reads:

DISPLAYMANAGER="KDE"

Then things will work fine.  I see two possible solutions:

1) Make the KDE Control Center smart enough to add the required line
to /etc/sysconfig/desktop when someone selects autologin

2) Make KDM and GDM understand each other's autologin requests

To me, option 2 seems like the better long term solution, but I don't
know exactly what that would involve.
Comment 1 Ngo Than 2004-08-17 06:09:58 EDT
*** Bug 108971 has been marked as a duplicate of this bug. ***
Comment 2 Doncho N. Gunchev 2004-09-27 18:22:47 EDT
With FC3t2 autologin with kdm still gives 'authentication failure' or
something like this, but does not work.
Comment 3 Ngo Than 2004-11-16 12:12:36 EST
it works fine with FC3 release. i have verified it on machine.
You have to enable autologin first (kcontrol->System
Aministration->Login Manager->Convennience)

Note You need to log in before you can comment on or make changes to this bug.