Bug 108971 - Autologin feature in the Control Center doesn't seem to work
Autologin feature in the Control Center doesn't seem to work
Status: CLOSED DUPLICATE of bug 111501
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 17:20 EST by Brent Fox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2003-11-03 17:20:04 EST
In the KDE Control Center, click on System Administration -> Login
Manager and then select the "Convenience" tab.  Click the button for
"Administrator Mode" and enter the root password.  Then enable
Automatic Login for a user.

In theory, the system should automatically log this user in the next
time the KDE starts.  However, this doesn't work for the following
reasons:

1) The /etc/X11/prefdm refers to the /usr/sbin/autologin program,
which we no longer ship.  

2) The autologin feature does not work with gdm...only with kdm.  The
problem is that to enable kdm, the user has to manually add
'DISPLAYMANAGER="KDE"' to /etc/sysconfig/desktop.


So I think that there are a few parts to fix this problem. 

1) Remove the autologin part from /etc/X11/prefdm since it's obsolete
(bug #108969)

2) One of the following:
   a) Have the KDE Control Center make the necessary changes to
/etc/sysconfig/desktop to start kdm, or
   b) Have the KDE Control Center pop up a dialog telling the user how
to manually change /etc/sysconfig/desktop to start kdm, or
   c) Make gdm allow the autologin feature to work, or
   d) Remove the autologin tab from KDE Control Center altogether

The current behavior is a bug in that it appears to the user that
autologin will work after selecting the autologin options, but there
are more hoops to jump through before autologin will actually work.
Comment 1 Doncho N. Gunchev 2004-08-17 04:23:42 EDT
    I think this bug, bug # 111501 and bug # 125924 are addressing one
problem. For me option d /Remove the autologin tab.../ is not an option.
Comment 2 Ngo Than 2004-08-17 06:09:56 EDT

*** This bug has been marked as a duplicate of 111501 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.