Bug 1115117 - Description of the bug fix 1050204 - WAIT_FOR_BEFORE_START does not work for / context applications is extremely hard to understand
Summary: Description of the bug fix 1050204 - WAIT_FOR_BEFORE_START does not work for ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: EAP 6.3.0
Assignee: Scott Mumford
QA Contact: Radim Hatlapatka
URL:
Whiteboard:
Depends On: 1050204
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-01 15:11 UTC by Radim Hatlapatka
Modified: 2014-08-14 15:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 22702, 6.3.0 Release Notes-6.3-1 Build Date: 30-06-2014 13:55:44 Topic ID: 35798-673002 [Latest]
Last Closed: 2014-08-06 14:38:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Radim Hatlapatka 2014-07-01 15:11:52 UTC
Description of the bug fix 1050204 - WAIT_FOR_BEFORE_START does not work for / context applications is not understandable

The main issue why it is not readable in an understandable way I see is overusing of /

the / means root context => / application doesn't make sense, it should be application deployed to / (or application deployed as root context)

Additionally WAIT_FOR_BEFORE_START is name of property (full name is org.apache.catalina.connector.WAIT_FOR_BEFORE_START) and not a feature name.

Please improve the text to make it more understandable.

Comment 3 Scott Mumford 2014-07-04 07:11:51 UTC
A new version of the 6.3.0 Release Notes is available for review at the below URL.

When verifying bugs please ensure you're viewing the latest version of the document (version 6.3.0-12 or later)

Stage:
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/6.3.0_Release_Notes/index.html

Build info:
https://brewweb.devel.redhat.com/taskinfo?taskID=7666962

Comment 4 Jakub Cechacek 2014-07-10 08:26:35 UTC
Even though I am not a native speaker the following part sounds weird to me

"This has been corrected in this release and now setting WAIT_FOR_BEFORE_START to / and deploy a root application, the connectors now start as expected."

Most likely this should be phrased more like


"This has been corrected in this release and now when setting WAIT_FOR_BEFORE_START to / and deploying a root application, the connectors will start as expected."


feel free to object as I might be wrong.

Comment 5 Scott Mumford 2014-07-15 02:26:29 UTC
You're absolutely right Jakub. That was an awkward way to phrase that sentence.

I've corrected it as per your suggestion. A new version will be available for review soon.

Comment 6 Scott Mumford 2014-07-15 04:36:22 UTC
A new build of the 6.3.0 Release Notes is available for review at:
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/6.3.0_Release_Notes/index.html

When verifying bugs, please ensure you're viewing the latest version of the document (6.3.0-14 or later)

Build details:
https://brewweb.devel.redhat.com/taskinfo?taskID=7700244

Comment 7 Scott Mumford 2014-07-15 04:36:53 UTC
A new build of the 6.3.0 Release Notes is available for review at:
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/6.3.0_Release_Notes/index.html

When verifying bugs, please ensure you're viewing the latest version of the document (6.3.0-14 or later)

Build details:
https://brewweb.devel.redhat.com/taskinfo?taskID=7700244

Comment 8 Jakub Cechacek 2014-07-15 06:50:42 UTC
Seems like the change did not go through -- RN still contain the exact sentence I was complaining about. 

Can you confirm Scott?

Comment 9 Scott Mumford 2014-07-16 03:48:40 UTC
Hmmm. It's showing as expected in the Doc Text field of the bug itself (which is where the text is drawn from to compile the document.

Perhaps there was timimg issue between making the change and rebuilding the document (our BugDash tool isn't real-time, unfortunately).

Hopefully it'll appear as intended in the next build.

Comment 10 Scott Mumford 2014-07-24 05:07:29 UTC
A new build of the 6.3.0 Release Notes is available for review at:
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/6.3.0_Release_Notes/index.html

When verifying bugs, please ensure you're viewing the latest version of the document (6.3.0-16 or later)

Build details:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=7730483

Comment 11 Jakub Cechacek 2014-07-24 07:01:40 UTC
Verified eap 6.3.0.ER10


Note You need to log in before you can comment on or make changes to this bug.