Bug 111545 - Connections to postgresql fail
Summary: Connections to postgresql fail
Status: CLOSED DUPLICATE of bug 112470
Alias: None
Product: Fedora
Classification: Fedora
Component: php   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 113836 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-05 03:41 UTC by Rob Riggs
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 112470
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Riggs 2003-12-05 03:41:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Connections to postgresql database fails with:
"Cannot create new link. Too many open links (0)"

Version-Release number of selected component (if applicable):
php-4.3.3-6

How reproducible:
Always

Steps to Reproduce:
1.create postgresql database
2.create php page to access postgresql database
3.access php page with browser
    

Actual Results:  Cannot create new link. Too many open links (0)

Expected Results:  I expected to get the proper php output.

Additional info:

This is caused by duplicate "extension=pgsql.so" directives, once in
/etc/php.ini and again in /etc/php.d/pgsql.ini.

I assume one will have the same problem with LDAP and IMAP, as these
directives are also duplicated.

As a workaround, one should comment out the extension directives
/etc/php.ini.

Comment 1 Joe Orton 2003-12-05 08:04:25 UTC
There are no extension= lines in /etc/php.ini as shipped in the php
package; these may be left over from an old version.

Comment 2 Rob Riggs 2003-12-06 01:23:16 UTC
Apologies.  You are correct.  I missed the php.ini.rpmnew file that
was installed.

Comment 3 Edward Pilipczuk 2004-01-21 16:20:45 UTC
*** Bug 113836 has been marked as a duplicate of this bug. ***

Comment 4 Joe Orton 2004-01-21 16:24:16 UTC
Reopend to mark as duplicate.

Comment 5 Joe Orton 2004-01-21 16:25:37 UTC
Excuse the noise: reopened again to *really* mark as duplicate.

Comment 6 Joe Orton 2004-01-21 16:26:00 UTC

*** This bug has been marked as a duplicate of 112470 ***

Comment 7 Red Hat Bugzilla 2006-02-21 19:00:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.