Bug 112470 - extension= lines not removed from php.ini on upgrade
Summary: extension= lines not removed from php.ini on upgrade
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: 1
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 111545 116780 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-20 10:07 UTC by Dietmar Kling
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 10:15:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Php ini that produces the error (23.17 KB, text/plain)
2004-01-10 10:50 UTC, Dietmar Kling
no flags Details
Specific Errors of php with the php.ini that doesn't work (37.09 KB, text/plain)
2004-01-10 10:58 UTC, Dietmar Kling
no flags Details

Description Dietmar Kling 2003-12-20 10:07:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031114

Description of problem:
Warning: pg_connect(): Cannot create new link. Too many open links
(0). in /var/www/html/test.php on line 3

There is no connection open to postgres 
Postgres does work. Can connect with psql and do selects
port 5432 does work

test.php to reproduc
<?php
 $conn = pg_connect("host='localhost' user='myuser' password='xx'  
dbname='mydb' port=5432");

?>
~


Version-Release number of selected component (if applicable):
4.3.3-6

How reproducible:
Always

Steps to Reproduce:
1. install test.php 
2. run test.php
3.
    

Actual Results:  error message in my browser

Expected Results:  connect to database
(this works with psql and i can do selects)

Additional info:

This Fedora Core 1 with all updates

Comment 1 Dietmar Kling 2003-12-25 10:27:58 UTC
i recompiled with php-4.3.4.

It still didn't work. 

Then replaced my original (working before i upgraded to fedora) redhat 9
/etc/php.ini 
with the rpmnew
of my 4.3.4 
and GUESS WHAT?

It started to work!

Comment 2 Joe Orton 2004-01-07 17:09:57 UTC
Can you attach your /etc/php.ini?  What happens if you change the
pgsql.max_links setting in php.ini to e.g.

pgsql.max_links = 100


Comment 3 Dietmar Kling 2004-01-10 10:50:00 UTC
Created attachment 96873 [details]
Php ini that produces the error

Comment 4 Dietmar Kling 2004-01-10 10:58:06 UTC
Created attachment 96874 [details]
Specific Errors of php with the php.ini that doesn't work

Somehow the registring of pgsql module doesn't work.

Comment 5 Joe Orton 2004-01-13 15:22:44 UTC
OK, thanks.  It's a migration issue: when upgrading to FC1 from RHL9
or earlier, /etc/php.ini needs to be edited to remove the
inappropriate extension= lines which are now loaded via /etc/php.d/*.ini.

Comment 6 Joe Orton 2004-01-21 16:26:02 UTC
*** Bug 111545 has been marked as a duplicate of this bug. ***

Comment 7 Joe Orton 2004-01-21 17:39:55 UTC
Fixed in 4.3.4-5 in Raw Hide: leaving this report open to be fixed in
future FC1 updates.

Comment 8 Joe Orton 2005-01-13 10:20:59 UTC
*** Bug 116780 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.