Bug 1115986 - RFE: provide connection failure reason in the error dialog
Summary: RFE: provide connection failure reason in the error dialog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1116048 1140870
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-03 13:07 UTC by David Jaša
Modified: 2015-03-05 13:39 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.6.0-6.el7
Doc Type: Enhancement
Doc Text:
Feature: When a connection failure happens, provide a detailed reason in the error dialog instead of a generic "Unable to connect to the graphic server SPICE_URI" message."
Clone Of:
: 1140870 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:39:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0295 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2015-03-05 17:33:00 UTC

Description David Jaša 2014-07-03 13:07:13 UTC
Description of problem:
When connection to spice-server fails, user is presented with unified error message "Unable to connect to the graphic server SPICE_URI". It would be nice to display the actual connection failure that spice-gtk gives, such as:
$ SPICE_PROXY=nonsense remote-viewer spice://localhost:5900/
(remote-viewer:2006): GSpice-WARNING **: Error resolving 'nonsense': Name or service not known

Version-Release number of selected component (if applicable):
virt-viewer-0.5.7-7.el7.x86_64
spice-gtk3-0.20-8.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. run remote-viewer in a way that r-v will fail to connect
2.
3.

Actual results:
only generic message is presented to user in error dialog

Expected results:
a detailed error message from spice-gtk library is given to the user

Additional info:
spice-gtk error messages would appreciate some love as well in order to be useful to point to original connection failure but that might be another step after virt-viewer/remote-viewer displays stuff that is already available

Comment 2 Marc-Andre Lureau 2014-07-03 16:51:37 UTC
and also: https://www.redhat.com/archives/virt-tools-list/2014-July/msg00031.html

Comment 3 CongDong 2014-09-16 03:26:17 UTC
Test with virt-viewer-0.6.0-5.el7.x86_64,

Steps:
1. Prepare two hosts: A and B, install a spice guest with 127.0.0.1 listen address on  host A
# virsh dumpxml $vm
...
    <graphics type='spice' port='5900' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
    </graphics>
...
2. on host B, connect the guest
# remote-viewer spice://$host_A_ip:$port

Cannot connect the guest, error msg in terminal:

(remote-viewer:23958): GSpice-WARNING **: Could not connect to 10.66.4.226: Connection refused

An error dialog comes out with msg:
Unable to connect to the graphic server spice://10.66.4.226:5900


3. Also connect to a void ip:
# remote-viewer spice://1.2.3.4:5900

Cannot connect the guest, errmsg in terminal:
(remote-viewer:24395): GSpice-WARNING **: Could not connect to 1.2.3.4: Socket I/O timed out

An error dialog comes out with msg:
Unable to connect to the graphic server spice://1.2.3.4:5900

As the result, the reason is not shown on the dialog, so set ASSINGED.

Comment 4 Christophe Fergeau 2014-09-16 08:48:58 UTC
Yes, this is a known issue, one patch is missing.

Comment 6 CongDong 2014-09-19 02:02:20 UTC
Test with:virt-viewer-0.6.0-6.el7.x86_64.rpm

Steps are same with comment 3:

Result:
Step 2, 
An error dialog comes out:
Unable to connect to the graphic server spice://10.66.5.15:5900
Could not connect to 10.66.5.15: Connection refused

Step 3:
An error dialog comes out:
Unable to connect to the graphic server spice://1.2.3.4:5900
Could not connect to 1.2.3.4: Socket I/O timed out

As the result, move to VERIFIED

Comment 7 Jiri Herrmann 2014-12-12 15:31:20 UTC
If this Feature should be included in the 7.1 Release Notes, could you please change the Doc Type from Enhancement to "Release Note"?

Note that the Release Notes are intended to list the most prominent and customer-relevant new features rather than every single enhancement.

Cheers,
Jirka

Comment 8 Marc-Andre Lureau 2014-12-12 15:35:54 UTC
not necessary

Comment 10 errata-xmlrpc 2015-03-05 13:39:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html


Note You need to log in before you can comment on or make changes to this bug.