Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
There is no difference in error message between connection failure to destination server or http proxy along the way. These messages should be differentiated
Version-Release number of selected component (if applicable):
spice-gtk3-0.20-8.el7.x86_64
How reproducible:
always
Steps to Reproduce:
run
$ SPICE_PROXY=nonsense.example.com remote-viewer spice://nonsense.example.com:5900/
$ remote-viewer spice://nonsense.example.com:5900/
Actual results:
ouptut in both cases is:
(remote-viewer:LINE_NO): GSpice-WARNING **: Error resolving 'nonsense.example.com': Name or service not known
The only difference is line number (24579 vs 24587)
Expected results:
The messages are sufficiently different to tell apart if failed connection to the proxy or to the server
Additional info:
Comment 1Marc-Andre Lureau
2014-07-03 15:23:05 UTC
(In reply to David Jaša from comment #0)
> Steps to Reproduce:
> run
> $ SPICE_PROXY=nonsense.example.com remote-viewer
> spice://nonsense.example.com:5900/
> $ remote-viewer spice://nonsense.example.com:5900/
>
> Actual results:
> ouptut in both cases is:
> (remote-viewer:LINE_NO): GSpice-WARNING **: Error resolving
> 'nonsense.example.com': Name or service not known
> The only difference is line number (24579 vs 24587)
It's not lineno, it's pid :)
>
> Expected results:
> The messages are sufficiently different to tell apart if failed connection
> to the proxy or to the server
>
> Additional info:
Just for info, firefox for example has a different error for proxy:
"Unable to find the proxy server
Firefox is configured to use a proxy server that can't be found."
Comment 2Marc-Andre Lureau
2014-07-06 22:37:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHBA-2015-0297.html