Bug 1116066 - Unable to delete Organization
Summary: Unable to delete Organization
Keywords:
Status: CLOSED DUPLICATE of bug 1100311
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-03 16:22 UTC by Greg Freestone
Modified: 2014-07-21 18:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 12:45:57 UTC


Attachments (Terms of Use)

Description Greg Freestone 2014-07-03 16:22:49 UTC
Description of problem:

hammer -u $user -p $passwd organization delete --id $id  
Could not delete the organization:
  Error: The server does not support such operation.

Delete not available un UI as well.

Verbose:
hammer -v -u $user -p $passwd organization delete --id $id
[ERROR 2014-07-03 10:20:37 Exception] Error: The server does not support such operation.
Could not delete the organization:
  Error: The server does not support such operation.
[ERROR 2014-07-03 10:20:37 Exception] 

HammerCLI::OperationNotSupportedError (The server does not support such operation.):
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/lib/hammer_cli/./apipie/command.rb:44:in `send_request'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_foreman-0.1.1/lib/hammer_cli_foreman/commands.rb:154:in `send_request'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/lib/hammer_cli/./apipie/command.rb:33:in `execute'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_foreman-0.1.1/lib/hammer_cli_foreman/resource_supported_test.rb:9:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/lib/hammer_cli/./apipie/../abstract.rb:22:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/lib/hammer_cli/./apipie/../abstract.rb:22:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/lib/hammer_cli/./apipie/../abstract.rb:22:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.1/bin/hammer:100
    /usr/bin/hammer:19:in `load'
    /usr/bin/hammer:19



Version-Release number of selected component (if applicable):
6.0.3

How reproducible:
Happens ever time

Steps to Reproduce:
1. Try to delete organization

Actual results:
Organization not deleted

Expected results:
Organization deleted.

Comment 1 RHEL Product and Program Management 2014-07-03 16:27:06 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2014-07-08 12:45:57 UTC
Due to issues with organization deletion, it was disabled in the beta.  Those issues are being resolved for the GA and are being worked on with bug 110311.

*** This bug has been marked as a duplicate of bug 1100311 ***


Note You need to log in before you can comment on or make changes to this bug.