Bug 11163 - "network restart" and "ifup eth*" behave differently from bootup
Summary: "network restart" and "ifup eth*" behave differently from bootup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-01 22:08 UTC by Eric Jorgensen
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-31 21:27:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Jorgensen 2000-05-01 22:08:39 UTC
After a normal bootup all interfaces including ip aliases have a
corresponding /32 route. After "/etc/rc.d/init.d/network restart" only the
primary address for each interface has a /32 route.

Comment 1 Eric Jorgensen 2000-05-02 22:19:59 UTC
after further investigative tweeking, any ifup-eth*:* that contains a
DEVICE="whatever" line gets a corresponding /32 route on ifup. If this is by
design I'm curous why . . .

Comment 2 Eric Jorgensen 2000-05-08 18:59:59 UTC
additionally, when using multiple addresses in a single ifcfg-eth#:# file,
bootup is identical to reloading the network.

it doesn't affect the behavior of the system, it's just curious i guess.

Comment 3 Bill Nottingham 2000-05-31 21:27:16 UTC
*** Bug 11400 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2000-05-31 21:34:51 UTC
Should be fixed in initscripts-5.14-1.


Note You need to log in before you can comment on or make changes to this bug.