Bug 11400 - ifup virtual interface bug
Summary: ifup virtual interface bug
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 11602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-13 19:28 UTC by thomas.mangin
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-01 08:41:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description thomas.mangin 2000-05-13 19:28:20 UTC
Using ifup to bring a new virtual interface (eth0:0) can in some case add a
second 0.0.0.0 route which screw up the network.

Comment 1 Bill Nottingham 2000-05-31 21:26:37 UTC
*** Bug 11602 has been marked as a duplicate of this bug. ***

Comment 2 thomas.mangin 2000-06-01 08:41:24 UTC
I disagree with the status of the bug resolution. I experience my problem with 
a redhat 6.2.
The problem appear if the interface is not started a boot time but added by 
hand with 
"ifconfig eth0:0 up" later on.

Configuration :

DEVICE=eth0
BOOTPROTO=static
BROADCAST=194.164.71.63
IPADDR=194.164.71.52
NETMASK=255.255.255.192
NETWORK=194.164.71.0
ONBOOT=yes

DEVICE=eth0:0
BOOTPROTO=static
BROADCAST=194.164.71.63
IPADDR=194.164.71.50
NETMASK=255.255.255.192
NETWORK=194.164.71.0
ONBOOT=no

DEVICE=eth1
BOOTPROTO=static
BROADCAST=192.168.0.255
IPADDR=192.168.0.1
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOT=yes


Before :

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.2     0.0.0.0         255.255.255.255 UH    0      0        0 eth1
194.164.71.52   0.0.0.0         255.255.255.255 UH    0      0        0 eth0
194.164.71.0    0.0.0.0         255.255.255.192 U     0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         194.164.71.62   0.0.0.0         UG    0      0        0 eth0

ifup eth0:0

After:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
194.164.71.50   0.0.0.0         255.255.255.255 UH    0      0        0 eth0
192.168.0.2     0.0.0.0         255.255.255.255 UH    0      0        0 eth1
194.164.71.52   0.0.0.0         255.255.255.255 UH    0      0        0 eth0
194.164.71.0    0.0.0.0         255.255.255.192 U     0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         194.164.71.62   0.0.0.0         UG    0      0        0 eth0
0.0.0.0         194.164.71.62   0.0.0.0         UG    0      0        0 eth0

The 194.164.71.62 is here twice ...

Thomas

Comment 3 Bill Nottingham 2000-06-01 15:38:31 UTC
This bug will be fixed in initscripts-5.14-1.


Note You need to log in before you can comment on or make changes to this bug.