Bug 1116323 - Removing callback to kdump script rhcrashkernel-param
Summary: Removing callback to kdump script rhcrashkernel-param
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1115914 1116335 1118527 1118529 1176483
Blocks: 1116331 1116338 1116340 1399436
TreeView+ depends on / blocked
 
Reported: 2014-07-04 08:50 UTC by Dave Young
Modified: 2016-11-29 04:49 UTC (History)
8 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1116331 1116338 (view as bug list)
Environment:
Last Closed: 2014-10-20 23:01:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Dave Young 2014-07-04 08:50:09 UTC
Description of problem:

Since currently crashkernel= will be handled in kdump anaconda addon we can safely remove rhcrashkernel-param callback.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vratislav Podzimek 2014-09-10 14:42:16 UTC
Dave, I guess you want this fixed on Fedora 21, right? If so, please change the Version field of this bug. Thanks!

Comment 3 Fedora Update System 2014-10-15 13:07:41 UTC
anaconda-21.48.10-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.10-1.fc21

Comment 4 Fedora Update System 2014-10-16 17:18:24 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-10-20 23:01:41 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Jonathan Briggs 2014-12-15 23:01:41 UTC
How exactly was this supposed to work with fedup upgrades? I have kdump that used to work and due to this change I believe, it no longer has the crashkernel commandline options. The kexec-tools-anaconda-addon was never installed. Maybe some other package needs to require it.

Comment 7 Vratislav Podzimek 2014-12-16 09:02:43 UTC
(In reply to Jonathan Briggs from comment #6)
> How exactly was this supposed to work with fedup upgrades? I have kdump that
> used to work and due to this change I believe, it no longer has the
> crashkernel commandline options. The kexec-tools-anaconda-addon was never
> installed. Maybe some other package needs to require it.
That's unrelated to this bug report. This bug report is about removing a piece of code from anaconda that now lives in the kdump-anaconda-addon. Upgrades, should, AFAICT preserve boot options like crashkernel and the same applies to installed packages, so that's a fedup bug, I think.

Comment 8 Jonathan Briggs 2014-12-16 16:43:53 UTC
It is all related and affects multiple packages. The rhcrashkernel-param program got removed from kexec. The anaconda code that called it got removed and put in a plugin.

The code itself was a line in /etc/sysconfig/grub that checked for rhcrashkernel-param and called it.

So the boot options that fedup was supposed to preserve do not exist in the grub2 source files anywhere after these changes. fedup would need some kind of special check just for this issue. It would have to somehow know to add the anaconda plugin based on the previous existance of kexec.

Comment 9 David Shea 2014-12-16 16:59:43 UTC
Anaconda is not used during a fedup upgrade. This bug is about anaconda using rhcrashkernel-param during installation to set up the kexec parameters. This bug has nothing to do with upgrades.

Since kexec-tools removes the program in question, /usr/sbin/rhcrashkernel-param, you should file a new bug against kexec-tools to handle changing config files during the package upgrade.


Note You need to log in before you can comment on or make changes to this bug.