Bug 1116829 - Unhandled exception on Firstboot screen, when launched firstboot screens on a already registered machine
Summary: Unhandled exception on Firstboot screen, when launched firstboot screens on ...
Keywords:
Status: CLOSED DUPLICATE of bug 1147425
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-07-07 12:15 UTC by Rehana
Modified: 2015-10-12 09:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-12 09:24:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
exception (296.76 KB, image/png)
2014-07-07 12:15 UTC, Rehana
no flags Details

Description Rehana 2014-07-07 12:15:26 UTC
Created attachment 916053 [details]
exception

Description of problem:


Version-Release number of selected component (if applicable):
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.7-1.el6
python-rhsm: 1.12.4-1.el6
# rpm -qa | grep subscription
subscription-manager-firstboot-1.12.7-1.el6.x86_64
subscription-manager-1.12.7-1.el6.x86_64
subscription-manager-debuginfo-1.12.7-1.el6.x86_64
subscription-manager-gui-1.12.7-1.el6.x86_64
subscription-manager-migration-data-2.0.8-1.el6.noarch
subscription-manager-migration-1.12.7-1.el6.x86_64


How reproducible:
3/3

Steps to Reproduce:
1.Register host machine to candlepin server
2.Now launch "Firstboot" from  terminal
3.Accept licence agreement and click next, 
4.click "forward" on setup software updates screen (with default options)

Actual results:
Exception occurred message window pops up (PFA:exception.png) 

Expected results:
On an already registered machine, the registration screens should be skipped and no exception should come

Additional info:

Comment 2 Adrian Likins 2014-08-14 19:29:19 UTC
This looks to be a bug in the firstboot modules in rhn-client-tools.

(walking past the end of an array if there are no "rhsm_" modules installed)

Comment 4 Tomas Lestach 2015-10-12 09:24:05 UTC
This has already been fixed. Closing as duplicate of Bug 1147425.

*** This bug has been marked as a duplicate of bug 1147425 ***


Note You need to log in before you can comment on or make changes to this bug.