Bug 1147425 - [en_US] [RHSM Firstboot] Exception Occurred when Forward in Choose Service page after registered and run in firstboot again.
Summary: [en_US] [RHSM Firstboot] Exception Occurred when Forward in Choose Service pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Matej Kollar
QA Contact: Pavel Studeník
URL:
Whiteboard:
: 1116829 (view as bug list)
Depends On:
Blocks: rhsm-rhel66 rhsm-rhel67
TreeView+ depends on / blocked
 
Reported: 2014-09-29 09:01 UTC by Lijun Li
Modified: 2015-10-12 09:24 UTC (History)
6 users (show)

Fixed In Version: rhn-client-tools-1.0.0.1-30-el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:28:57 UTC


Attachments (Terms of Use)
Exception Occurred (93.38 KB, image/png)
2014-09-29 09:03 UTC, Lijun Li
no flags Details
Exception_log (49.13 KB, text/plain)
2014-09-29 09:05 UTC, Lijun Li
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1395 normal SHIPPED_LIVE rhn-client-tools bug fix update 2015-07-20 18:07:31 UTC

Description Lijun Li 2014-09-29 09:01:37 UTC
Description of problem:
[en_US] [RHSM Firstboot] Exception Occurred when Forward in Choose Service page after registered and run in firstboot again.

Version-Release number of selected component (if applicable):
subscription-manager-1.12.14-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Register the system via RHSM GUI or Firstboot.
2. Run from terminal: firstboot --reconfig
3. Next to the Choose Service page.
4. Select Red Hat Subscription Management and Foward.

Actual results:
Exception Occurred when Forward in Choose Service page after registered and run in firstboot again.

Expected results:
No such Exception.

Additional info:
Please see the attached screen-shot and log file.

Comment 1 Lijun Li 2014-09-29 09:03:09 UTC
Created attachment 942238 [details]
Exception Occurred

Comment 2 Lijun Li 2014-09-29 09:05:27 UTC
Created attachment 942239 [details]
Exception_log

Comment 4 Bryan Kearney 2014-09-29 17:24:30 UTC
Moving bugs to 6.7

Comment 5 Bryan Kearney 2014-11-03 19:54:59 UTC
Moving bugs to 6.7

Comment 6 Adrian Likins 2015-02-23 17:02:19 UTC
(for easier reference)
firstboot 1.110.15 exception report
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/firstboot/interface.py", line 105, in _nextClicked
    self.advance()
  File "/usr/lib/python2.6/site-packages/firstboot/interface.py", line 148, in advance
    result = module.apply(self, self.testing)
  File "/usr/share/rhn/up2date_client/firstboot/rhn_choose_server_gui.py", line 58, in apply
    while not interface.moduleList[i].__module__.startswith('rhsm_'):
IndexError: list index out of range

Comment 7 Adrian Likins 2015-02-23 17:30:53 UTC
Any other logs from this (firstboot log maybe?).


I think on this crash, there are no rhsm module available to firstboot, because the system is already registered?  The rhsm_modules are skipped if the system is registered (via submans firstboot_base:RhsmFirstbootModule.shouldAppear().

In that case, the line 58 above eventually walks off the end of the modules list without finding a rhsm module and throws the index error. But not having rhsm modules in the modules list is a valid scenario (either because of running firstboot more than once, or if the system was registered in the kickstart).

Going to bounce this to rhn-client-tools for that.

Comment 13 Matej Kollar 2015-02-27 21:20:53 UTC
Upstream changes

Spacewalk.git
* a42a075c90342180fd9c4d8a8d3e66bc37f0846d
* 7315d8d8a006ba1872677fd83ffb5cb3502f100d

Comment 17 Pavel Studeník 2015-04-02 11:24:53 UTC
Verified with package rhn-setup-gnome-1.0.0.1-32.el6.noarch.rpm

Tested all combinations:

1) unregister to rhn X unregister to rhsm
2) register to rhn X unregister to rhsm
3) unregister to rhn X register to rhsm
3) register to rhn X register to rhsm

Comment 18 errata-xmlrpc 2015-07-22 07:28:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1395.html

Comment 19 Tomas Lestach 2015-10-12 09:24:05 UTC
*** Bug 1116829 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.