Bug 1117035 - prescript.pp attempts to compare string 7.0.1406 to the number 7
prescript.pp attempts to compare string 7.0.1406 to the number 7
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gaël Chamoulaud
Ami Jeain
:
: 1117255 1117873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-07 16:53 EDT by Rich Bowen
Modified: 2014-09-15 14:53 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2014.1-23.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 14:53:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
puppetlabs-firewall-pull-request-368.patch (2.49 KB, patch)
2014-07-09 17:29 EDT, Gaël Chamoulaud
gchamoul: review? (ichavero)
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 105493 None None None Never

  None (edit)
Description Rich Bowen 2014-07-07 16:53:23 EDT
Description of problem:

line 15 of prescript.pp attempts to compare the string 7.0.1406 to the number 7, resulting in failure of that module

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. run packstack --allinone
2.
3.

Actual results:

Line 15

 if $::operatingsystem in $el_releases and $::operatingsystemrelease < 7 {

fails with

 "Comparison of String with 7 failed"


Expected results:

Should be using operatingsystemmajrelease instead of operatingsystemrelease

Additional info:

Altering that comparison to operatingsystemmajrelease instead gets us past this comparison successfully.
Comment 1 Gaël Chamoulaud 2014-07-08 12:29:51 EDT
With the new version numbers of CentOS, this bug will impact the following upstream puppet modules:
- Keystone,
- MySQL,
- Nova,
- Firewall,
- Apache
- and Cinder.
Comment 2 Gaël Chamoulaud 2014-07-09 17:29:26 EDT
Created attachment 916955 [details]
puppetlabs-firewall-pull-request-368.patch
Comment 3 Lee Yarwood 2014-07-16 16:48:36 EDT
*** Bug 1117255 has been marked as a duplicate of this bug. ***
Comment 4 Gaël Chamoulaud 2014-07-23 06:37:35 EDT
The new CentOS versioning numbers was impacting the following components:
- Packstack,
- Puppet-nova,
- Puppetlabs-mysql,
- Puppetlabs-firewall,
- Puppetlabs-apache,
- Puppet-cinder,
- Openstack-puppet-modules.

The status report on this issue is:

# Packstack
- The patches has been already merged in master and icehouse branches [1]

# Puppet-nova
- The patches has been already merged in master and icehouse branches [2]

# Puppet-cinder
- The patches has been already merged in master and icehouse branches [3]

# Puppetlabs-mysql
- The patches has been already merged in icehouse branches [4]
- It has been merged upstream too [5]

# Puppetlabs-firewall
- the patch [6] are attached to this bz

# Puppetlabs-apache
- A fix was already committed upstream.
- The OPM Pull-Request containing this commit is in review and ready to be merged [7]

# Openstack-puppet-modules
- The following Pull-Requests containing fixes for puppet-nova and puppet-cinder are in review and ready to be merged [8][9]

[1] https://review.openstack.org/#/c/105493/
[2] https://review.openstack.org/105526 and https://review.openstack.org/105807
[3] https://review.openstack.org/105673 and https://review.openstack.org/105809
[4] https://github.com/packstack/puppetlabs-mysql/commit/a0bd625d1006320f8a7d0073b130606a9eacb86a
[5] https://github.com/puppetlabs/puppetlabs-mysql/commit/7b3cdd234a0498a8b64258ebf3399bf6f3899afb
[6] https://bugzilla.redhat.com/attachment.cgi?id=916955
[7] https://github.com/redhat-openstack/openstack-puppet-modules/pull/88
[8] https://github.com/redhat-openstack/openstack-puppet-modules/pull/87
[9] https://github.com/redhat-openstack/openstack-puppet-modules/pull/86
Comment 5 Gaël Chamoulaud 2014-07-23 06:48:46 EDT
*** Bug 1117873 has been marked as a duplicate of this bug. ***
Comment 6 dcvtruong 2014-08-12 14:39:37 EDT
Hi,

I'm getting the same error on CentOS 6.5 running "packstack --allinone".  Is there a solution for this error?


tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neu
tron nova nssdb openstack packstack qpid rabbitmq rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChec
king=no -o UserKnownHostsFile=/dev/null root@10.201.125.95 tar -C /var/tmp/packstack/496ed4082caa423d8f7515b8bb20b775/modules -xpzf -
2014-08-12 13:21:35::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 10.201.125.95_prescript.pp
Error: Command exceeded timeout
You will find full trace in log /var/tmp/packstack/20140812-125450-wH8cQS/manifests/10.201.125.95_prescript.pp.log

2014-08-12 13:21:35::INFO::shell::81::root:: [10.201.125.95] Executing script:
rm -rf /var/tmp/packstack/496ed4082caa423d8f7515b8bb20b775

DT
Comment 7 zhuifeng0426 2014-08-17 22:58:52 EDT
i Faced same issue when i use packstack to install openstack in 3 nodes(1 controller, 1 network, 1 compute) with GRE only, i didn't encounter this issue when i try to use VLAN.

This issue is 100% reproduciable.

2014-08-17 19:29:04::ERROR::run_setup::920::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 915, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 605, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 584, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 68, in runAllSequences
    sequence.run(config=self.CONF, messages=self.MESSAGES)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 98, in run
    step.run(config=config, messages=messages)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 44, in run
    raise SequenceError(str(ex))
SequenceError: Error appeared during Puppet run: 172.16.1.190_neutron.pp
Error: Could not set 'present' on ensure: can't convert nil into String at 80:/var/tmp/packstack/d6188006e23d4704821a8ffcfb0e7d40/mani
fests/172.16.1.190_neutron.pp
You will find full trace in log /var/tmp/packstack/20140817-185859-l_8SgR/manifests/172.16.1.190_neutron.pp.log


more /var/tmp/packstack/20140817-185859-l_8SgR/manifests/172.16.1.190_neutron.pp.log
<cnip>

Error: Could not set 'present' on ensure: can't convert nil into String at 80:/var/tmp/packstack/d6188006e23d4704821a8ffcfb0e7d4
0/manifests/172.16.1.190_neutron.pp
Error: Could not set 'present' on ensure: can't convert nil into String at 80:/var/tmp/packstack/d6188006e23d4704821a8ffcfb0e7d4
0/manifests/172.16.1.190_neutron.pp
Wrapped exception:
can't convert nil into String
Error: /Stage[main]/Main/Vs_port[eth1]/ensure: change from absent to present failed: Could not set 'present' on ensure: can't co
nvert nil into String at 80:/var/tmp/packstack/d6188006e23d4704821a8ffcfb0e7d40/manifests/172.16.1.190_neutron.pp
Comment 8 zhuifeng0426 2014-08-17 23:38:00 EDT
update:

VLAN mode also reports the same issue.
Comment 9 Alan Pevec 2014-09-15 14:53:48 EDT
Updated openstack-puppet-modules has been published to the RDO Icehouse repository.

Note You need to log in before you can comment on or make changes to this bug.