Bug 1117873 - Failure `packstack --allinone` install IceHouse on CentOS 7
Summary: Failure `packstack --allinone` install IceHouse on CentOS 7
Keywords:
Status: CLOSED DUPLICATE of bug 1117035
Alias: None
Product: RDO
Classification: Community
Component: openstack-packstack
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: Icehouse
Assignee: Gaël Chamoulaud
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 14:55 UTC by Boris Derzhavets
Modified: 2014-07-23 10:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 10:48:46 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 105526 0 None None None Never

Description Boris Derzhavets 2014-07-09 14:55:45 UTC
Fixed  mysql issue per https://bugzilla.redhat.com/show_bug.cgi?id=981116

Description of problem:


    Preparing servers                                [ DONE ]
    Installing Dependencies                          [ DONE ]
    Copying Puppet modules and manifests             [ DONE ]
    Applying 192.169.142.57_prescript.pp
    192.169.142.57_prescript.pp:                     [ DONE ]          
    Applying 192.169.142.57_mysql.pp
    Applying 192.169.142.57_amqp.pp
    192.169.142.57_mysql.pp:                          [ DONE ]      
    192.169.142.57_amqp.pp:                           [ DONE ]      
    Applying 192.169.142.57_keystone.pp
    Applying 192.169.142.57_glance.pp
    Applying 192.169.142.57_cinder.pp
    192.169.142.57_keystone.pp:                          [ DONE ]         
    192.169.142.57_cinder.pp:                            [ DONE ]         
    192.169.142.57_glance.pp:                            [ DONE ]         
    Applying 192.169.142.57_api_nova.pp
    192.169.142.57_api_nova.pp:                          [ DONE ]         
    Applying 192.169.142.57_nova.pp
    192.169.142.57_nova.pp:                           [ ERROR ]       
    Applying Puppet manifests                         [ ERROR ]

    ERROR : Error appeared during Puppet run: 192.169.142.57_nova.pp
    Error: /Service[messagebus]: Could not evaluate: Could not find init script for 'messagebus'
    You will find full trace in log /var/tmp/packstack/20140709-114849-pY1VcY/manifests/192.169.142.57_nova.pp.log
    Please check log file /var/tmp/packstack/20140709-114849-pY1VcY/openstack-setup.log for more information


Moreover if I create /etc/init.d/messagebus , I get attempt to start D-bus in old style :-

        192.169.142.57_nova.pp:                           [ ERROR ]       
        Applying Puppet manifests                         [ ERROR ]

        ERROR : Error appeared during Puppet run: 192.169.142.57_nova.pp
        Error: Could not start Service[messagebus]: Execution of '/etc/init.d/messagebus start' returned 127: Starting D-Bus daemon: /etc/init.d/messagebus: line 26: start-stop-daemon: command not found
        You will find full trace in log /var/tmp/packstack/20140709-170356-4RxF1Q/manifests/192.169.142.57_nova.pp.log
        Please check log file /var/tmp/packstack/20140709-170356-4RxF1Q/openstack-setup.log for more information

Packstack appears not to understand systemd folders content /lib/systemd/system/ ; /usr/lib/systemd/system/; /etc/systemd/system/


Version-Release number of selected component (if applicable):

IceHouse 2014.1

How reproducible:


Steps to Reproduce:
1. Install CentOS 7.0
2. Tune for packstack --allinone install
3. Run : packstack --allinone

Actual results:

Failure RDO AIO install


Expected results:

Success RDO AIO install 
Additional info:

Comment 2 Gaël Chamoulaud 2014-07-23 10:48:46 UTC
This bug is coming from the new CentOS versioning number. You will find a full status report on all the fixes for CentOS 7 in https://bugzilla.redhat.com/show_bug.cgi?id=1117035#c4

*** This bug has been marked as a duplicate of bug 1117035 ***


Note You need to log in before you can comment on or make changes to this bug.