Bug 111724 - redhat-config-printer and "Failed to write queues."
redhat-config-printer and "Failed to write queues."
Status: CLOSED DUPLICATE of bug 110652
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 07:00 EST by Ivo Sarak
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2003-12-09 07:00:39 EST
Description of problem:

redhat-config-printer will let me add printer definitions, but when to
 press "Apply" it will only report "Failed to write queues.".
It will update /etc/printcap, but no changes will land to
/tc/cups/printers.conf or cupsd.conf.

Version-Release number of selected component (if applicable):

redhat-config-printer-0.6.79-1
redhat-config-printer-0.6.79.2-1

How reproducible:
Always (on this machine).

Steps to Reproduce:
1. start redhat-config-printer
2. define a new printer (local or remote)
3. press "Apply"
  
Actual results:
"Failed to write queues."

Expected results:
Defined and usable printer.

Additional info:
I have reinstalled cups and redhat-config-printer, but with no change
in behaviour.

One thing I find strange - there are these files starting with "lp" on
this box:
[root@sarmax cups]# lp
lp2pap.sh    lpc.cups     lpmove       lpq.cups     lprsetup.sh
lpadmin      lp.cups      lpoptions    lpr.cups     lpstat.cups
lpasswd      lpinfo       lppasswd     lprm.cups    lpunlock
[root@sarmax cups]#
but on another box with printers running:
[root@skhal root]# lp
lp           lpc          lpmove       lpq.cups     lprm.cups    lpunlock
lp2pap.sh    lpc.cups     lpoptions    lpr          lprsetup.sh
lpadmin      lp.cups      lppasswd     lpr.cups     lpstat
lpasswd      lpinfo       lpq          lprm         lpstat.cups
[root@skhal root]#

Why these list are different?
I suspect the redhat-config-printer will look for "lpr/lpc" and not
"lpr.cups/lpc.cups" and that is why it is failing.
Comment 1 Tim Waugh 2003-12-09 07:05:45 EST
Is this an upgrade?  If so, from which release?
Comment 2 Ivo Sarak 2003-12-09 10:53:55 EST
This box has upgraded a lot and I do not know exactly when the
printing died on this box, maybe around 9.0.93...

File list of /var/spool/up2date:

# ls -la
total 10560
drwxr-xr-x    2 root     root         4096 Dec  9 17:46 .
drwxr-x---   30 root     root         4096 Dec  9 17:46 ..
-rw-r--r--    1 root     root       568093 Nov 20 22:40
fedora-core-1.20031104162434
-rw-r--r--    1 root     root       176433 Nov 20 22:41
fedora-core-1-obsoletes.1000
-rw-r--r--    1 root     root      5253983 Oct 29 12:32
rawhide.20031028113515
-rw-r--r--    1 root     root       468032 Dec 28  2002
redhat-linux-beta-i386-phoebe.20021223103210
-rw-r--r--    1 root     root       477885 Jan 25  2003
redhat-linux-beta-i386-phoebe-8.0.93.20030124115314
-rw-r--r--    1 root     root       189452 Jan 25  2003
redhat-linux-beta-i386-phoebe-8.0.93-obsoletes.20030124115314
-rw-r--r--    1 root     root          131 Jan 31  2003
redhat-linux-beta-i386-phoebe-8.0.93-obsoletesBlacklist.20030124115314
-rw-r--r--    1 root     root       475848 Feb 25  2003
redhat-linux-beta-i386-phoebe-8.0.94.20030220134516
-rw-r--r--    1 root     root       190783 Feb 25  2003
redhat-linux-beta-i386-phoebe-8.0.94-obsoletes.20030220134516
-rw-r--r--    1 root     root          131 Feb 25  2003
redhat-linux-beta-i386-phoebe-8.0.94-obsoletesBlacklist.20030220134516
-rw-r--r--    1 root     root       188822 Dec 28  2002
redhat-linux-beta-i386-phoebe-obsoletes.20021223103210
-rw-r--r--    1 root     root       478291 Jan 22  2003
redhat-linux-i386-8.0.20030120162421
-rw-r--r--    1 root     root       170854 Jan 22  2003
redhat-linux-i386-8.0-obsoletes.20030120162421
-rw-r--r--    1 root     root       452057 Aug  2 12:13
redhat-linux-i386-9.20030729120621
-rw-r--r--    1 root     root       190593 Aug  2 12:13
redhat-linux-i386-9-obsoletes.20030729120621
-rw-r--r--    1 root     root       486438 Sep 16 20:39
redhat-linux-severn-i386-9.0.93.20030825113751
-rw-r--r--    1 root     root       190181 Sep 16 20:39
redhat-linux-severn-i386-9.0.93-obsoletes.20030825113751
-rw-r--r--    1 root     root       505685 Sep 22 21:43
redhat-linux-severn-i386-9.0.93-updates.20030919101121
-rw-r--r--    1 root     root       195353 Sep 22 21:43
redhat-linux-severn-i386-9.0.93-updates-obsoletes.20030919101121
-rw-r--r--    1 root     root        19474 Dec  3 19:22
updates-released.20031202033408
-rw-r--r--    1 root     root          131 Nov 20 22:41
updates-released-obsoletes.1000
Comment 3 Tim Waugh 2003-12-09 10:55:48 EST
Run redhat-switch-printer.

*** This bug has been marked as a duplicate of 110652 ***
Comment 4 Ivo Sarak 2003-12-09 11:22:09 EST
Thanks. 
It seems that I got printing working again.
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.