Bug 110652 - Incomplete conversion from LPRng to CUPS
Incomplete conversion from LPRng to CUPS
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 111724 111787 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-21 23:30 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 21:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-21 23:30:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
After an upgrade from RH 7.3 to Fedora Core 1, the LPRng -> CUPS
conversion was incomplete.  All LPRng components were removed, and all
CUPS components were installed.  However, the system was still
configured to use LPRng, so printing was non-functional.

Version-Release number of selected component (if applicable):
anaconda-9.2-2

How reproducible:
Didn't try

Steps to Reproduce:
1. Configure a system with RedHat Linux 7.3.
2. Configure one or more printers using LPRng.
3. Upgrade the system to Fedora Core 1.
    

Actual Results:  Printing subsystem non-functional.  printconf-gui
reports "Cannot write to queues" or "/usr/bin/lpr not found" when
applying any changes or trying to print a test page.

Expected Results:  Printing subsystem should have functioned normally

Additional info:

The following steps were necessary to re-establish printing functionality:

/sbin/chkconfig add cups
/etc/initd.d/cups restart
/usr/sbin/alternatives --config print, and select option '1'

In addition, after verifying that printing worked, I did:

/usr/sbin/alternatives --auto print
Comment 1 Tim Waugh 2003-12-09 10:55:49 EST
*** Bug 111724 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2003-12-10 04:16:18 EST
*** Bug 111787 has been marked as a duplicate of this bug. ***
Comment 3 Eli 2004-02-06 19:43:33 EST
I didn't find the solution described above, but wound up 'fixing' it 
this way: 
 
# cd /etc/alternatives 
# ls print* | awk '{print $NF, $(NF-2)}' | sed 's/LPRng/cups/g' | \ 
  xargs -n2 ln -sf 
 
(I also started cups.  Based on the earlier solution, I'll have to 
do a bit more to keep it fixed.) 
 
This is a _very_ ugly problem.  I spent a lot of time trying to find 
a pointer to explain what was going on. 
 
GRRRR 
Comment 4 Jim Harvey 2004-03-01 23:21:41 EST
Same problem observed here upgrading RH9 to core 1.  I just deleted
the bad symlinks for lpq, lpr, lprm and lpstat in /usr/bin and
relinked them to the cups version there.  Havent tried a reboot to see
if cups starts ok, I did /etc/rc.d/init.d/cups restart before I fixed
the symlinks.

Also I had to re-add my two printers. Used the HTML GUI for that.
Comment 5 John Thacker 2006-04-21 21:00:34 EDT
Annoying, but I really don't think that upgrading from RH7.3 or RH9 to FC1 (or 4
or 5 or anything) is going to be supported at this point.

Note You need to log in before you can comment on or make changes to this bug.