Bug 111729 - Piranha with FOS and send_program: monitoring script is not launched
Piranha with FOS and send_program: monitoring script is not launched
Status: CLOSED DUPLICATE of bug 73073
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McLean
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 09:06 EST by Pierre Amadio
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Amadio 2003-12-09 09:06:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030417

Description of problem:
When using piranha with a fail over service and monitoring the service
with the send_program , it looks like the send_program is not even
launched.

I was not ablr making it work although monitoring with the regular
send and except strings worked perfectly.

So i had a test creating a FOS http service with some false monitoring
script that would always return OK , plus adding an entry in some log
file:

#!/bin/sh
echo "OK"
echo `date` $1 >> /tmp/log

lvs.conf:
serial_no = 19
primary = 172.16.10.140
service = fos
backup_active = 1
backup = 172.16.10.141
heartbeat = 1
heartbeat_port = 539
keepalive = 6
deadtime = 18
network = direct
reservation_conflict_action = preempt
debug_level = NONE
failover [server_name] {
     address = 172.16.10.145 eth0:1
     vip_nmask = 255.255.255.0
     active = 1
     timeout = 6
     expect = "OK"
     send_program = "/usr/local/lvsScript/apache_control.sh %h"
     start_cmd = "/etc/init.d/httpd start"
     stop_cmd = "/etc/init.d/httpd stop"
}

Then i launched pulse on both director. After a short while, a fail of
service condition appears an the master is told to be the backup while
the backup become the master.

However, no entry are created in /tmp/log wich means the monitoring
script has not even been called.



Version-Release number of selected component (if applicable):
piranha-0.7.0-5

How reproducible:
Always

Steps to Reproduce:
1.install a piranha with a fos service (httpd) on two directors
2.use a send_program script to monitor the service

    

Actual Results:  the monitoring always think the service is down, the
send_program is not called

Expected Results:  the send_program shall be called, and its output
interpreted.

Additional info:
Comment 1 Mike McLean 2003-12-09 11:17:57 EST

*** This bug has been marked as a duplicate of 73073 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.