Bug 73073 - FOS not running correctly
FOS not running correctly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: piranha (Show other bugs)
2.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 111729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 08:38 EDT by Sébastien BONNET
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 17:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch correcting type (send_str -> send_program) (457 bytes, patch)
2002-08-30 08:39 EDT, Sébastien BONNET
no flags Details | Diff

  None (edit)
Description Sébastien BONNET 2002-08-30 08:38:00 EDT
Description of Problem:
fos does not correctly handle the send_program config directive which badly 
alters failover capabilities


Version-Release number of selected component (if applicable):
0.7.0


How Reproducible:
Anytime when using a send_program. Alter util.c and uncomment piranha_log in 
logArgv. Start pulse -v. Watch out the logs and notice that nanny isn't passed 
the right args (everything's missing after -e).


Actual Results:
send_program is not executed, thus fos thinks the service is never available. 
This causes the inactive node to failover anytime.


Expected Results:
When executed on the inactive node, the send_program should notice and report 
back to nanny than the active node is all right.
Comment 1 Sébastien BONNET 2002-08-30 08:39:33 EDT
Created attachment 73944 [details]
Patch correcting type (send_str -> send_program)
Comment 2 Mike McLean 2003-05-06 19:10:10 EDT
FOS is being removed from piranha.
Comment 3 Mike McLean 2003-12-09 11:17:59 EST
*** Bug 111729 has been marked as a duplicate of this bug. ***
Comment 7 Lon Hohberger 2004-11-09 13:19:26 EST
Info re: patch:

It's a one-line fix which exists in later revisions of piranha. 
No-impact patch.
Comment 8 Lon Hohberger 2005-07-29 12:54:27 EDT
I added this to the 0.7.11 package, which is expected to go out with U6.
Comment 9 Lon Hohberger 2005-07-29 12:55:53 EDT
Whoops, that was a RHEL3 update, not 2.1...  Argh.
Comment 10 Lon Hohberger 2005-08-02 17:07:14 EDT
Not fixing for RHEL2.1

Note You need to log in before you can comment on or make changes to this bug.