Bug 1117422 - Can't install wine from EPEL on CentOS 7
Summary: Can't install wine from EPEL on CentOS 7
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1117938 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 16:30 UTC by Chris Paulson-Ellis
Modified: 2015-07-23 02:13 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-12 21:35:07 UTC


Attachments (Terms of Use)
meta package fixes (1.57 KB, patch)
2014-07-09 05:47 UTC, Michael Cronenworth
no flags Details | Diff
epel fixes (2.98 KB, patch)
2014-07-10 05:44 UTC, Michael Cronenworth
no flags Details | Diff

Description Chris Paulson-Ellis 2014-07-08 16:30:19 UTC
On CentOS 7, x86_64 with the EPEL 7 yum repository...

$ sudo yum install wine
...
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-twain(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-ldap(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-pulseaudio(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-cms(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-core(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-capi(x86-32) = 1.7.21-1.el7
Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-openal(x86-32) = 1.7.21-1.el7
Error: Package: wine-desktop-1.7.21-1.el7.x86_64 (epel)
           Requires: wine-core(x86-32) = 1.7.21-1.el7

Comment 1 Michael Cronenworth 2014-07-08 21:44:30 UTC
Red Hat dropped support for 32-bit in RHEL7. The main wine package will attempt to pull in both arches since it is simply a meta package. A workaround for now would be to directly install each package. This will only install 64-bit packages and will only run 64-bit Windows applications.

# yum install wine-core wine-wow wine-pulseaudio ...

@Bjoern (besser82), please ask the Wine maintainers (Andreas and myself) or test with scratch builds in the future before building updates. That is not what provenpackager status is for.

Comment 2 Michael Cronenworth 2014-07-09 05:47:54 UTC
Created attachment 916628 [details]
meta package fixes

All, here is a patch for the meta package. If this looks good (or I don't see comments) I'm going to push it and push builds.

Here's an EPEL7 scratch build if you want to test it: http://koji.fedoraproject.org/koji/taskinfo?taskID=7119583

Comment 3 Constantin Dunayev 2014-07-09 07:50:55 UTC
(In reply to Michael Cronenworth from comment #2)
> Here's an EPEL7 scratch build if you want to test it:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=7119583

wine-desktop in this build still requires wine-core(x86-32)

Comment 4 Chris Paulson-Ellis 2014-07-09 08:52:14 UTC
I can still run 32-bit ELF executables on CentOS 7 even though there is no 32-bit kernel or installer - I've installed {glibc,glib2,etc}.i686.

Not surprisingly, the Windows PE executables I need to run are 32-bit too. Is there no chance of supporting it - short of using Fedora, which is what I'm trying to migrate from?

Comment 5 Constantin Dunayev 2014-07-09 10:04:40 UTC
Red Hat DID NOT drop support for 32-bit applications, there are 32-bit packages in main repositories, but EPEL haven't any 32-bit packages in it

Comment 6 Michael Cronenworth 2014-07-09 12:55:47 UTC
(In reply to Constantin Dunayev from comment #3)
> wine-desktop in this build still requires wine-core(x86-32)

Ah, good catch. I'll fix this.

(In reply to Chris Paulson-Ellis from comment #4)
> I can still run 32-bit ELF executables on CentOS 7 even though there is no
> 32-bit kernel or installer - I've installed {glibc,glib2,etc}.i686.

RHEL7 has a bare minimum 32-bit multi-lib environment. It has to otherwise it would alienate a lot of RHEL customers who use proprietary, closed-source 32-bit software. This does not mean wine can be built for 32-bit.

> Not surprisingly, the Windows PE executables I need to run are 32-bit too.
> Is there no chance of supporting it - short of using Fedora, which is what
> I'm trying to migrate from?

There is no chance.

(In reply to Constantin Dunayev from comment #5)
> Red Hat DID NOT drop support for 32-bit applications, there are 32-bit
> packages in main repositories, but EPEL haven't any 32-bit packages in it

https://lists.fedoraproject.org/pipermail/epel-devel/2014-March/009297.html

Comment 7 Michael Cronenworth 2014-07-09 16:35:38 UTC
*** Bug 1117938 has been marked as a duplicate of this bug. ***

Comment 8 Michael Cronenworth 2014-07-10 05:44:11 UTC
Created attachment 916996 [details]
epel fixes

After testing on CentOS 7 I had to also create a symlink for wine64/wine. Here's the updated patch and scratch build.

http://koji.fedoraproject.org/koji/taskinfo?taskID=7123305

Comment 9 Fabian Arrotin 2014-07-10 11:40:12 UTC
Well, the other solution (what I did here) is to rebuild the wine SRPM (and all needed deps) for i386/i686.
But that also means pointing a specific custom mock config file to CentOS 7 i386 to populate a buildroot (doesn't work against RHEL 7)
I would like to know the official Epel opinion about Epel i386 (or not)

Comment 10 Michael Cronenworth 2014-07-12 21:35:07 UTC
I've pushed a 1.7.22 build.

http://koji.fedoraproject.org/koji/buildinfo?buildID=543550

Comment 11 Ken Stailey 2014-08-08 14:15:53 UTC
In case you arrived at this bugzilla bug via Google you might want to look at this forum thread about how to rebuild EPEL wine RPMs as 32-bit.

https://www.centos.org/forums/viewtopic.php?f=48&t=47325&p=203055#p203055


Note You need to log in before you can comment on or make changes to this bug.