Bug 1117938 - wine: broken x86-32 dependencies
Summary: wine: broken x86-32 dependencies
Keywords:
Status: CLOSED DUPLICATE of bug 1117422
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:31 UTC by Seb L.
Modified: 2014-07-09 16:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 16:35:38 UTC


Attachments (Terms of Use)

Description Seb L. 2014-07-09 16:31:00 UTC
Description of problem:
  Unable to install wine due to broken (x86-32) dependencies
 

Version-Release number of selected component (if applicable):
  wine-1.7.21-1.el7.x86_64


How reproducible:
  Always


Steps to Reproduce:
  yum install wine


Actual results:
  Install fails:

  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-twain(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-ldap(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-pulseaudio(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-cms(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-core(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-capi(x86-32) = 1.7.21-1.el7
  Error: Package: wine-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-openal(x86-32) = 1.7.21-1.el7
  Error: Package: wine-desktop-1.7.21-1.el7.x86_64 (epel)
             Requires: wine-core(x86-32) = 1.7.21-1.el7


Expected results:
  wine should install


Additional info:
  All x86-32 dependencies are missing since EPEL 7 is x86-64 only
  The missing x86-32 packages should be built or the x86-32 dependencies
  should be dropped.

Comment 1 Michael Cronenworth 2014-07-09 16:35:38 UTC

*** This bug has been marked as a duplicate of bug 1117422 ***


Note You need to log in before you can comment on or make changes to this bug.