Bug 111754 - Graphic installer fails on Dell Inspiron 4000
Summary: Graphic installer fails on Dell Inspiron 4000
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-09 17:39 UTC by Pierre F. Maldague
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 18:38:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre F. Maldague 2003-12-09 17:39:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
Graphical installer fails to start on a Dell Inspiron 4000 laptop. The
video card is correctly identified:  ATI Technologies Inc Rage
Mobility M3 AGP 2x rev 2, Mem @ 0xf8000000/26, 0xfdffc000/14, I/O @
0xec00/8
but "no screen could be found".


This was a fresh install -- clean disk -- not an update.

Possible factor: I had a MS Intellimouse plugged into the USB port;
didn't think to unplug it to see if it made any difference.

Text install was successful. During post-install login as root, X
failed to start again. After a quick web search on another machine I
located some random XF86Config file advertised to work w/Dell
inspiron, ssh'd it in, and started X w/o trouble.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-35.EL

How reproducible:
Always

Steps to Reproduce:
1.stick RHEL-3 install CD # 1 into Dell Inspiron 4000
2.hit enter for normal install
3.watch X fail
    

Actual Results:  X fails twice and message appears "you can safely
reboot now"

Expected Results:  The graphic installer should have been displayed in
all its glory

Additional info:

Same problem occurred with RH 9. I didn't notice when I installed RH 9
last year because I did an update, not a fresh install.

Comment 1 Mike A. Harris 2004-01-26 16:56:14 UTC
Please attach the config file our tool creates, and the log file
from an X server session attempt, and then a copy of the config file
that works, and a log file from that session, using uncompressed
individual bugzilla file attachments using the link below.

Thanks in advance.

Comment 2 Mike A. Harris 2005-03-06 18:37:22 UTC
A number of XFree86 and kernel updates have been released for
RHEL 3 since the initial RHEL 3 release.  Please ensure you
are running the current RHEL 3 update, with all erratum applied,
and are booted into the latest kernel.

If the problem persists with the latest updates, please contact
Red Hat global support services at 1-888-RED-HAT1 and a support
representative will assist.

Thanks.

Comment 3 Mike A. Harris 2005-03-06 18:38:40 UTC
Setting status to "ERRATA" as the current errata releases
may resolve this issue.

Comment 4 Mike A. Harris 2005-03-06 18:45:00 UTC
*** Bug 116997 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.