Bug 1117888 - Problem when enabling quota : Could not start quota auxiliary mount
Summary: Problem when enabling quota : Could not start quota auxiliary mount
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota   
(Show other bugs)
Version: 3.5.1
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Triaged
Depends On:
Blocks: glusterfs-3.5.8 1302541
TreeView+ depends on / blocked
 
Reported: 2014-07-09 15:18 UTC by NOVELTIS IT
Modified: 2016-09-20 04:29 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.5.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1302541 (view as bug list)
Environment:
Last Closed: 2016-03-04 11:15:13 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description NOVELTIS IT 2014-07-09 15:18:48 UTC
Description of problem: When trying to enable quota, the following message appears :

quota: Could not start quota auxiliary mount
Quota command failed. Please check the cli logs for more details

in logs [2014-07-09 13:20:09.066609] E [cli-cmd-volume.c:1036:gf_cli_create_auxiliary_mount] 0-cli: Failed to create auxiliary mount directory /var/run/gluster/projets/. Reason : No such file or directory

If I create /var/run/gluster folder, it works.

Version-Release number of selected component (if applicable): 3.5.1


How reproducible: Install 3.5.1 server release on a Debian Wheezy (3 peer), create a volume and enable quota

Actual results:


Expected results: the folder /var/run/gluster must be created when quota is enabled.


Additional info: none

Comment 1 Niels de Vos 2014-07-19 17:59:52 UTC
This issue is only seen on Debian (and derivatives). The RPM packages create the /var/run/gluster directory.

The fix for this should be two-fold:
1. cli-cmd-volume.c:gf_cli_create_auxiliary_mount() should create the dir if it
   is missing
2. 'make install' should create the /var/run/gluster (or other ./configure'd) dir

Comment 2 Niels de Vos 2014-07-19 18:03:00 UTC
(In reply to Niels de Vos from comment #1)
> 1. cli-cmd-volume.c:gf_cli_create_auxiliary_mount() should create the dir if
>    it is missing

Actually, gf_cli_create_auxiliary_mount() is probably the wrong place for the fix. It is up to the bits of the for the start of the quota process which uses this dir.

Comment 3 Niels de Vos 2014-10-05 08:53:44 UTC
The change for mainline has not been posted/merged yet. I'm preparing a beta for glusterfs-3.5.3 without this change. Hopefully a fix will land in time for glusterfs-3.5.4.

Comment 4 Richard 2015-05-20 10:17:21 UTC
This is still a problem in 3.7.0.

readv on /var/run/gluster/quotad.socket failed

Comment 5 Richard 2015-05-20 10:19:26 UTC
confusing thing is that file exists:

$ ls -al /var/run/gluster/quotad.socket
srwxr-xr-x 1 root root 0 May 20 10:52 /var/run/gluster/quotad.socket

Comment 6 Niels de Vos 2015-09-15 14:09:44 UTC
There were no patches submitted in time for the glusterfs-3.5.6 release that should resolve this bug. This bug report is moved for tracking to the glusterfs-3.5.7 release, submitting patches/backports is very much appreciated.

Comment 7 Vijaikumar Mallikarjuna 2015-12-21 09:17:00 UTC
Hi Richard,

If file '/var/run/gluster/quotad.socket' doesn't exists then open should have failed.
readv on /var/run/gluster/quotad.socket failed could be a different issue.

could you provide the complete log information?

Thanks,
Vijay

Comment 8 Richard 2015-12-21 11:27:13 UTC
I'm sorry but I don't use GlusterFS any more... I gave up as it had too many issues for my use. However, from memory I don't think this is an issue with the newer versions of the software so you could probably close this bug report as 'fixed'?

Comment 9 André Bauer 2016-01-06 13:41:59 UTC
Problem exists in Glusterfs 3.5.7 in Ubuntu

Comment 10 Manikandan 2016-01-11 06:24:07 UTC
Hi,

We are not able to reproduce the problem with glusterfs 3.5.7 in Ubuntu. Enabling quota worked fine without any errors for us. May I know which version of Ubuntu are you using ? Please let us know if there is a different way to reproduce this issue. Also, it would be helpful if you could mail us the complete log details(to mselvaga@redhat.com).

--
Thanks & Regards,
Manikandan Selvaganesh.

Comment 11 André Bauer 2016-01-11 09:38:32 UTC
I use the GlusterFS Packages from the offical PPA @ https://launchpad.net/~gluster since Glusterfs 3.2. or 3.3 on Ubuntu 14.04.

Used Quota the first time last week. Had to create the directorys by hand to get it work.

I'm afraid the logs are not available anymore but its the same error like in the initial bugreport. Found it while googling for the same error.

Comment 12 Vijay Bellur 2016-01-11 12:48:14 UTC
REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#1) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 13 Vijay Bellur 2016-01-11 12:51:57 UTC
REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#2) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 14 Manikandan 2016-01-11 12:58:50 UTC
Hi,

Thanks for your inputs. Sorry, it was my mistake. I ran with some old binaries. I am able to reproduce the issue now. 

I have fixed the issue and a patch[1] has been sent upstream. You could expect the fix in the next upcoming minor release of 3.5.

[1] http://review.gluster.org/#/c/13215/


--
Thanks & Regards,
Manikandan Selvaganesh.

Comment 15 Vijay Bellur 2016-01-11 13:37:38 UTC
REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#3) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 16 Vijay Bellur 2016-01-28 06:26:58 UTC
REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#4) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 17 Vijay Bellur 2016-01-28 06:28:42 UTC
REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#5) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 18 Vijay Bellur 2016-02-12 08:28:49 UTC
COMMIT: http://review.gluster.org/13215 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit e61a2171f2389ec6cf1be962b68609c2e763cbd9
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Jan 11 18:08:27 2016 +0530

    quota : fix could not start auxiliary mount issue
    
    In versions older than 3.7, when trying to enable
    quota, the following message appears :"quota: Could
    not start quota auxiliary mount". It was because,
    /var/run/gluster was not getting created in cli side.
    In 3.7, the code has been moved to glusterd and we are
    making use of sys_mkdir.
    
    3.6 fix -> http://review.gluster.org/#/c/13308/
    
    
    Change-Id: Id4360409f76b57c0f676fe2b859f3647c4340575
    BUG: 1117888
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13215
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>

Comment 19 Niels de Vos 2016-03-04 11:15:13 UTC
GlusterFS 3.5.8 has been released and should fix this bug:

http://www.gluster.org/pipermail/announce/2016-March/000054.html


Note You need to log in before you can comment on or make changes to this bug.