Bug 1302541 - Problem when enabling quota : Could not start quota auxiliary mount
Problem when enabling quota : Could not start quota auxiliary mount
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.6.8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: EasyFix, Triaged
Depends On: 1117888
Blocks: glusterfs-3.6.9
  Show dependency treegraph
 
Reported: 2016-01-28 01:17 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-glusterfs-3.6.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1117888
Environment:
Last Closed: 2016-03-04 10:26:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2016-01-28 01:17:26 EST
+++ This bug was initially created as a clone of Bug #1117888 +++

Description of problem: When trying to enable quota, the following message appears :

quota: Could not start quota auxiliary mount
Quota command failed. Please check the cli logs for more details

in logs [2014-07-09 13:20:09.066609] E [cli-cmd-volume.c:1036:gf_cli_create_auxiliary_mount] 0-cli: Failed to create auxiliary mount directory /var/run/gluster/projets/. Reason : No such file or directory

If I create /var/run/gluster folder, it works.

Version-Release number of selected component (if applicable): 3.5.1


How reproducible: Install 3.5.1 server release on a Debian Wheezy (3 peer), create a volume and enable quota

Actual results:


Expected results: the folder /var/run/gluster must be created when quota is enabled.


Additional info: none

--- Additional comment from Niels de Vos on 2014-07-19 13:59:52 EDT ---

This issue is only seen on Debian (and derivatives). The RPM packages create the /var/run/gluster directory.

The fix for this should be two-fold:
1. cli-cmd-volume.c:gf_cli_create_auxiliary_mount() should create the dir if it
   is missing
2. 'make install' should create the /var/run/gluster (or other ./configure'd) dir

--- Additional comment from Niels de Vos on 2014-07-19 14:03:00 EDT ---

(In reply to Niels de Vos from comment #1)
> 1. cli-cmd-volume.c:gf_cli_create_auxiliary_mount() should create the dir if
>    it is missing

Actually, gf_cli_create_auxiliary_mount() is probably the wrong place for the fix. It is up to the bits of the for the start of the quota process which uses this dir.

--- Additional comment from Niels de Vos on 2014-10-05 04:53:44 EDT ---

The change for mainline has not been posted/merged yet. I'm preparing a beta for glusterfs-3.5.3 without this change. Hopefully a fix will land in time for glusterfs-3.5.4.

--- Additional comment from Richard on 2015-05-20 06:17:21 EDT ---

This is still a problem in 3.7.0.

readv on /var/run/gluster/quotad.socket failed

--- Additional comment from Richard on 2015-05-20 06:19:26 EDT ---

confusing thing is that file exists:

$ ls -al /var/run/gluster/quotad.socket
srwxr-xr-x 1 root root 0 May 20 10:52 /var/run/gluster/quotad.socket

--- Additional comment from Niels de Vos on 2015-09-15 10:09:44 EDT ---

There were no patches submitted in time for the glusterfs-3.5.6 release that should resolve this bug. This bug report is moved for tracking to the glusterfs-3.5.7 release, submitting patches/backports is very much appreciated.

--- Additional comment from Vijaikumar Mallikarjuna on 2015-12-21 04:17:00 EST ---

Hi Richard,

If file '/var/run/gluster/quotad.socket' doesn't exists then open should have failed.
readv on /var/run/gluster/quotad.socket failed could be a different issue.

could you provide the complete log information?

Thanks,
Vijay

--- Additional comment from Richard on 2015-12-21 06:27:13 EST ---

I'm sorry but I don't use GlusterFS any more... I gave up as it had too many issues for my use. However, from memory I don't think this is an issue with the newer versions of the software so you could probably close this bug report as 'fixed'?

--- Additional comment from André Bauer on 2016-01-06 08:41:59 EST ---

Problem exists in Glusterfs 3.5.7 in Ubuntu

--- Additional comment from Manikandan on 2016-01-11 01:24:07 EST ---

Hi,

We are not able to reproduce the problem with glusterfs 3.5.7 in Ubuntu. Enabling quota worked fine without any errors for us. May I know which version of Ubuntu are you using ? Please let us know if there is a different way to reproduce this issue. Also, it would be helpful if you could mail us the complete log details(to mselvaga@redhat.com).

--
Thanks & Regards,
Manikandan Selvaganesh.

--- Additional comment from André Bauer on 2016-01-11 04:38:32 EST ---

I use the GlusterFS Packages from the offical PPA @ https://launchpad.net/~gluster since Glusterfs 3.2. or 3.3 on Ubuntu 14.04.

Used Quota the first time last week. Had to create the directorys by hand to get it work.

I'm afraid the logs are not available anymore but its the same error like in the initial bugreport. Found it while googling for the same error.

--- Additional comment from Vijay Bellur on 2016-01-11 07:48:14 EST ---

REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#1) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-11 07:51:57 EST ---

REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#2) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Manikandan on 2016-01-11 07:58:50 EST ---

Hi,

Thanks for your inputs. Sorry, it was my mistake. I ran with some old binaries. I am able to reproduce the issue now. 

I have fixed the issue and a patch[1] has been sent upstream. You could expect the fix in the next upcoming minor release of 3.5.

[1] http://review.gluster.org/#/c/13215/


--
Thanks & Regards,
Manikandan Selvaganesh.

--- Additional comment from Vijay Bellur on 2016-01-11 08:37:38 EST ---

REVIEW: http://review.gluster.org/13215 (quota : fix could not start auxiliary mount issue) posted (#3) for review on release-3.5 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 1 Vijay Bellur 2016-01-28 01:25:28 EST
REVIEW: http://review.gluster.org/13308 (quota : fix could not start auxiliary mount issue) posted (#1) for review on release-3.6 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-02-02 21:47:31 EST
REVIEW: http://review.gluster.org/13308 (quota : fix could not start auxiliary mount issue) posted (#2) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 3 Vijay Bellur 2016-02-03 14:25:13 EST
REVIEW: http://review.gluster.org/13308 (quota : fix could not start auxiliary mount issue) posted (#3) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 4 Vijay Bellur 2016-02-24 11:27:03 EST
COMMIT: http://review.gluster.org/13308 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 52f6c664a27cddad37196c91fbb4c03d7da774b3
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Mon Jan 11 18:08:27 2016 +0530

    quota : fix could not start auxiliary mount issue
    
    In versions older than 3.7, when trying to enable
    quota, the following message appears :"quota: Could
    not start quota auxiliary mount". It was because,
    /var/run/gluster was not getting created in cli side.
    In 3.7, the code has been moved to glusterd and we are
    making use of sys_mkdir.
    
    3.5 fix -> http://review.gluster.org/#/c/13215/
    
    > Change-Id: Id4360409f76b57c0f676fe2b859f3647c4340575
    > BUG: 1117888
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    
    Change-Id: Id4360409f76b57c0f676fe2b859f3647c4340575
    BUG: 1302541
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13308
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Raghavendra Bhat 2016-03-04 10:57:40 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.6.9, please open a new bug report.

glusterfs-glusterfs-3.6.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2016-March/048584.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.