Bug 1117921 - Wrong releaseversion picked up when doing 'make -C extras/LinuxRPM glusterrpms'
Summary: Wrong releaseversion picked up when doing 'make -C extras/LinuxRPM glusterrpms'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anders Blomdell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.6.0
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:01 UTC by Anders Blomdell
Modified: 2015-05-14 17:42 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
Clean autom4te.cache and run recipie automatically (940 bytes, patch)
2014-07-09 16:01 UTC, Anders Blomdell
no flags Details | Diff

Description Anders Blomdell 2014-07-09 16:01:08 UTC
Created attachment 916875 [details]
Clean autom4te.cache and run recipie automatically

Description of problem:

The recipie in http://www.gluster.org/community/documentation/index.php/CompilingRPMS for building RPMS's is missing one crucial step:


  $ ./autogen.sh
  $ ./configure --enable-fusermount
  $ make dist
  ...
  $ cd extras/LinuxRPM
  $ make glusterrpms

should be:

  $ rm -f ./autom4te.cache/*   # make sure to use current
                             # './build-aux/pkg-version --release'
  $ ./autogen.sh 
  $ ./configure --enable-fusermount 
  $ make dist 
  ...
  $ cd extras/LinuxRPM
  $ make glusterrpms

Otherwise the rpm's wont pick the correct releaseversion, i.e. ./autogen.sh
will pickup the result of './build-aux/pkg-version --release' from the cache
instead of figure out where HEAD is currently located.

Version-Release number of selected component (if applicable):

3.6.0 (2c5eb5c708134218bf756cffeb5167bd03499028)

How reproducible:

When new commits has been done after the last autogen

Steps to Reproduce:
1. Follow step in recipie
2. make -C extras/LinuxRPM glusterrpms
3. make some commits
4. make -C extras/LinuxRPM glusterrpms

Actual results:

The last set of RPM's has the same version as the first

Expected results:

Version number should reflect the commits done.

Additional info:

Comment 1 Anders Blomdell 2014-07-09 16:06:25 UTC
It would be nice to have a tag in the master tree that reflects the current target release (v3.6.0.prerelease perhaps), as it is now it picks up v3.5qa2 which makes the locally build rpms be replaced by a yum update :-(

A local tag is easy, but...

Comment 2 Justin Clift 2014-07-09 20:31:08 UTC
Actually, yeah, we were going to look into that v3.5qa2 version thing.  I'll see if we can't get a 3.6.0 related tag onto master soonish.  We might time it for the 3.6 feature freeze or something.

Comment 3 Anand Avati 2014-07-10 19:01:51 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 4 Anand Avati 2014-07-11 15:56:15 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#2) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 5 Anand Avati 2014-07-11 17:17:36 UTC
REVIEW: http://review.gluster.org/8299 (Use C-locale for numeric/string routines (strtod, ...) or config file parsing might fail.) posted (#1) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 6 Anders Blomdell 2014-07-11 17:23:42 UTC
(In reply to Anand Avati from comment #5)
> REVIEW: http://review.gluster.org/8299 (Use C-locale for numeric/string
> routines (strtod, ...) or config file parsing might fail.) posted (#1) for
> review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Wrong bug number entered when submitting to gerrit, please ignore.

Comment 7 Anand Avati 2014-07-14 07:32:56 UTC
REVIEW: http://review.gluster.org/8299 (Use C-locale for numeric/string routines (strtod, ...) or config file parsing might fail.) posted (#3) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 8 Anand Avati 2014-07-14 09:40:10 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#3) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 9 Anand Avati 2014-07-14 09:49:56 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#4) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 10 Anand Avati 2014-07-14 09:59:26 UTC
REVIEW: http://review.gluster.org/8299 (Use C-locale for numeric/string routines (strtod, ...) or config file parsing might fail.) posted (#4) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 11 Anand Avati 2014-07-14 14:24:48 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#5) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 12 Anand Avati 2014-07-14 14:30:36 UTC
REVIEW: http://review.gluster.org/8299 (Use C-locale for numeric/string conversion routines) posted (#5) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 13 Anand Avati 2014-07-15 12:59:55 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#6) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 14 Anand Avati 2014-07-15 13:07:00 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#7) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 15 Anand Avati 2014-07-15 14:08:11 UTC
REVIEW: http://review.gluster.org/8293 (Make RPM's with current git tag) posted (#8) for review on master by Anders Blomdell (anders.blomdell@control.lth.se)

Comment 16 Anand Avati 2014-07-30 15:07:17 UTC
COMMIT: http://review.gluster.org/8293 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit e8a1fc34ad3891e8b739278a909dbd91c56b9f4e
Author: Anders Blomdell <anders.blomdell@control.lth.se>
Date:   Tue Jul 8 15:36:45 2014 +0200

    Make RPM's with current git tag
    
    1. clear autom4te.cache
    2. autogen.sh
    3. configure --with-previous-options
    
    Change-Id: I90c1820d22207d18b1bb367444b21918467baea5
    BUG: 1117921
    Signed-off-by: Anders Blomdell <anders.blomdell@control.lth.se>
    Reviewed-on: http://review.gluster.org/8293
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-by: Humble Devassy Chirammal <humble.devassy@gmail.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 17 Niels de Vos 2015-05-14 17:26:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 18 Niels de Vos 2015-05-14 17:35:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 19 Niels de Vos 2015-05-14 17:37:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 20 Niels de Vos 2015-05-14 17:42:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.