Bug 1117984 - capsule-installer: check for validity of --certs-tar file location before commencing.
Summary: capsule-installer: check for validity of --certs-tar file location before com...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1131635 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2014-07-09 18:57 UTC by Corey Welton
Modified: 2019-04-01 20:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:02:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 17643 None None None 2016-12-12 19:05:19 UTC

Description Corey Welton 2014-07-09 18:57:59 UTC
Description of problem:
If the filename entered for --certs-tar is not correct, the installer will commence and eventually error out for confusing reasons.  We should do some sanity checking to make sure the filename passed to --certs-tar is valid before starting install.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140702.0

How reproducible:


Steps to Reproduce:
1.  On main instance, create cert for target capsule and copy to target
2.  Attempt to install capsule, but use an incorrect string for the certs.tar file, i.e. cloud-qe-4.idm.lab.bos.redhat.com-certs.tra (note the typo)
3.  View results

Actual results:
Process errors out and user has to dig pretty deep into the log to figure out why the install failed; it is not really clear that it is due to a bad value passed to --certs-tar

Expected results:
We should validate the value passed to --certs-tar before ever executing.

Additional info:

Comment 2 Mike McCune 2014-08-21 19:54:47 UTC
*** Bug 1131635 has been marked as a duplicate of this bug. ***

Comment 7 David O'Brien 2016-04-18 00:47:46 UTC
Reset docs contact <> daobrien

Comment 9 Chris Roberts 2016-12-12 18:38:06 UTC
Created Redmine issue:

http://projects.theforeman.org/issues/17643

Comment 10 Bryan Kearney 2016-12-12 21:13:15 UTC
Upstream bug component is Installer

Comment 11 Bryan Kearney 2016-12-14 21:13:12 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/17643 has been resolved.

Comment 12 Bryan Kearney 2017-08-01 20:02:12 UTC
The fix to this bug will be delivered with release 6.3 of Satellite.


Note You need to log in before you can comment on or make changes to this bug.