Bug 1118072 - Storage restore procedure is necessary for all rhq tables
Summary: Storage restore procedure is necessary for all rhq tables
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: JON 3.3.0
Assignee: Jared MORGAN
QA Contact: Mike Foley
Jared MORGAN
URL:
Whiteboard:
: 1136816 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 00:17 UTC by Eiichi Nagai
Modified: 2018-12-06 17:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
It was discovered that missing tables in the storage restore procedure were preventing all relevant data from being correctly restored. Improvements to the procedure in https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.3/html/Admin_and_Config/storage-restore.html now include all affected tables, and fixes the originally-reported issue.
Clone Of:
Environment:
[Admin_Config] Ready for review.
Last Closed: 2014-12-11 14:04:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Eiichi Nagai 2014-07-10 00:17:34 UTC
Description of problem:
The restore procedure documentation is explaining only for "metrics_index" table[1]. However, the procedure is necessary for other tables[2] as well.

[1] https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Admin_and_Config/storage-restore.html

[2]
 - rhq-data/data/rhq/metrics_index
 - rhq-data/data/rhq/one_hour_metrics
 - rhq-data/data/rhq/raw_metrics
 - rhq-data/data/rhq/schema_version
 - rhq-data/data/rhq/six_hour_metrics
 - rhq-data/data/rhq/twenty_four_hour_metrics

Version-Release number of selected component (if applicable):
JON 3.2

Comment 3 Jared MORGAN 2014-10-22 02:30:55 UTC
svn commit -m "tabl"
Sending        en-US/Admin_and_Config.xml
Sending        en-US/MetricsDB.xml
Transmitting file data ..
Committed revision 98007.

In Step 3, I noted that in the original 3.2 docs, there was a rhq-data/data/data/ path that just didn't look correct. I've removed this, but if it is required, then  I can add it back again.

In Step 4, I left the user in the rhq directory because this is where they would be if they followed the procedure to date. I assumed that by now the customer would understand the directory pattern and could substitute paths as required in the procedure. 

http://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.3/html/Admin_and_Config/storage-restore.html will show the changes once published.

Comment 5 Jared MORGAN 2014-11-06 23:53:18 UTC
*** Bug 1136816 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.