Bug 1118187 - Cannot run VMs on host while VM is migrating to it
Summary: Cannot run VMs on host while VM is migrating to it
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.3
Assignee: Arik
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
: 1123079 (view as bug list)
Depends On: 1064931
Blocks: 1107968 1110126
TreeView+ depends on / blocked
 
Reported: 2014-07-10 07:31 UTC by Michal Skrivanek
Modified: 2014-07-30 07:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1064931
Environment:
Last Closed: 2014-07-18 09:37:36 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24799 None None None Never
oVirt gerrit 29892 ovirt-engine-3.4.3 MERGED core: minor cleanup in MigrateVDSCommand Never
oVirt gerrit 29893 ovirt-engine-3.4.3 MERGED core: make migrate commands non-transactive Never

Description Michal Skrivanek 2014-07-10 07:31:46 UTC
we want this in 3.4.z as it has a major impact

+++ This bug was initially created as a clone of Bug #1064931 +++

Description of problem:
MigrateVmCommand is transactive from some reason. When it is scheduling a host it also increases the pending resources on that host, thus locking the host in the DB until the execute phase is done. Since RunVm command will also tries to update the pending resources on the scheduled host, in case the scheduled host is destination host in migration process, it won't be possible to update them and the RunVm command will have to wait until the execute phase of the migration ends (which can be long in case of failures & reruns)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Migrate VM to host X
2. Stop (with debugger) right after scheduling the host
3. Try to run another VM on host X

Actual results:
The run command won't end

Expected results:
The VM we try to run on host X need to start.

Additional info:
We need to get rid of the transaction in migrate commands

Comment 1 Sandro Bonazzola 2014-07-18 09:37:36 UTC
This is an automated message

oVirt 3.4.3 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.

Comment 2 Omer Frenkel 2014-07-30 07:17:54 UTC
*** Bug 1123079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.