Bug 1118266 - nautilus crashes while unmounting a device
Summary: nautilus crashes while unmounting a device
Keywords:
Status: CLOSED DUPLICATE of bug 1254161
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Carlos Soriano
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1203710
TreeView+ depends on / blocked
 
Reported: 2014-07-10 10:21 UTC by Siteshwar Vashisht
Modified: 2015-11-24 18:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-24 18:24:26 UTC


Attachments (Terms of Use)
Cleanup NautilusFile object properly (383 bytes, patch)
2014-07-10 11:11 UTC, Siteshwar Vashisht
no flags Details | Diff
backtrace (30.49 KB, text/plain)
2015-08-03 12:19 UTC, Vladimir Benes
no flags Details

Description Siteshwar Vashisht 2014-07-10 10:21:01 UTC
Description of problem:
nautilus crashes while unmounting a device

Version-Release number of selected component (if applicable):
nautilus-3.8.2-7.el7.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
Crash happens sometimes when unmouting a device.

Additional info:
Upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=708282

Comment 1 Siteshwar Vashisht 2014-07-10 11:11:58 UTC
Created attachment 917045 [details]
Cleanup NautilusFile object properly

Backported patch from https://bugzilla.gnome.org/attachment.cgi?id=275585

Comment 3 Siteshwar Vashisht 2014-07-11 14:42:07 UTC
Backtrace :

#0  0x00007fe5608da989 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x00007fe5608da989 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007fe5608dc098 in __GI_abort () at abort.c:90
#2  0x00007fe56199b186 in g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x503763 "nautilus-bookmark.c", line=line@entry=350, func=func@entry=0x503d70 <__PRETTY_FUNCTION__.48352> "nautilus_bookmark_connect_file", 
    message=<optimized out>) at gtestutils.c:1912
#3  0x00007fe56199b1e4 in g_assertion_message_expr (domain=domain@entry=0x0, file=file@entry=0x503763 "nautilus-bookmark.c", line=line@entry=350, func=func@entry=0x503d70 <__PRETTY_FUNCTION__.48352> "nautilus_bookmark_connect_file", 
    expr=expr@entry=0x503a78 "!nautilus_file_is_gone (bookmark->details->file)") at gtestutils.c:1923
#4  0x0000000000485049 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xf05df0) at nautilus-bookmark.c:350
#5  0x0000000000485094 in nautilus_bookmark_constructed (obj=<optimized out>) at nautilus-bookmark.c:549
#6  0x00007fe561c6d485 in g_object_newv (object_type=object_type@entry=12315888, n_parameters=n_parameters@entry=3, parameters=parameters@entry=0x12a8820) at gobject.c:1747
#7  0x00007fe561c6d816 in g_object_new_valist (object_type=object_type@entry=12315888, first_property_name=first_property_name@entry=0x4fffc4 "location", var_args=var_args@entry=0x7fff977d3e30) at gobject.c:1836
#8  0x00007fe561c6db91 in g_object_new (object_type=12315888, first_property_name=first_property_name@entry=0x4fffc4 "location") at gobject.c:1551
#9  0x0000000000485424 in nautilus_bookmark_new (location=location@entry=0x7fe54c067180, custom_name=custom_name@entry=0x12ac050 "") at nautilus-bookmark.c:756
#10 0x0000000000478ed0 in nautilus_window_slot_update_bookmark (file=0x120f7e0, slot=0xb95600) at nautilus-window-slot.c:1848
#11 nautilus_window_slot_update_for_new_location (slot=0xb95600) at nautilus-window-slot.c:2133
#12 location_has_really_changed (slot=0xb95600) at nautilus-window-slot.c:2389
#13 view_begin_loading_cb (view=<optimized out>, slot=0xb95600) at nautilus-window-slot.c:2310
#14 0x00007fe561c66af8 in g_closure_invoke (closure=0x112b960, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fff977d4130, invocation_hint=invocation_hint@entry=0x7fff977d40d0)
    at gclosure.c:777
#15 0x00007fe561c781ad in signal_emit_unlocked_R (node=node@entry=0xf14b90, detail=detail@entry=0, instance=instance@entry=0x106e380, emission_return=emission_return@entry=0x0, 
    instance_and_params=instance_and_params@entry=0x7fff977d4130) at gsignal.c:3584
#16 0x00007fe561c7ff8a in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fff977d42b0) at gsignal.c:3328
#17 0x00007fe561c8023f in g_signal_emit (instance=instance@entry=0x106e380, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3384
#18 0x00000000004687eb in finish_loading (view=0x106e380) at nautilus-view.c:9144
#19 finish_loading_if_all_metadata_loaded (view=view@entry=0x106e380) at nautilus-view.c:9203
#20 0x0000000000468af3 in metadata_for_directory_as_file_ready_callback (file=0x120f7e0, callback_data=0x106e380) at nautilus-view.c:9223
#21 0x00000000004a76f3 in call_ready_callbacks_at_idle (callback_data=<optimized out>) at nautilus-directory-async.c:1855
#22 0x00007fe561976ac6 in g_main_dispatch (context=0xb64c10) at gmain.c:3058
#23 g_main_context_dispatch (context=context@entry=0xb64c10) at gmain.c:3634
#24 0x00007fe561976e48 in g_main_context_iterate (context=context@entry=0xb64c10, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3705
#25 0x00007fe561976efc in g_main_context_iteration (context=0xb64c10, context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3766
#26 0x00007fe561f3eb84 in g_application_run (application=0xb42000, argc=argc@entry=2, argv=argv@entry=0x7fff977d4668) at gapplication.c:1623
#27 0x000000000042a3db in main (argc=2, argv=0x7fff977d4668) at nautilus-main.c:104

Comment 5 Siteshwar Vashisht 2014-07-14 13:47:59 UTC
Related upstream bug report at https://bugzilla.gnome.org/show_bug.cgi?id=710986

Comment 7 Siteshwar Vashisht 2014-09-04 08:34:51 UTC
Natuilus still crashes with patch from #6 but the stacktrace is different :

#0  0x00007fe5608da989 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007fe5608dc098 in __GI_abort () at abort.c:90
#2  0x00007fe56199b186 in g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x503763 "8", line=line@entry=350, func=func@entry=0x503d70 "bookmark_file_changed_callback", message=<optimized out>) at gtestutils.c:1912
#3  0x00007fe56199b1e4 in g_assertion_message_expr (domain=0x0, file=0x503763 "8", line=350, func=0x503d70 "bookmark_file_changed_callback", expr=<optimized out>) at gtestutils.c:1923
#4  0x0000000000485049 in nautilus_bookmark_connect_file ()
#5  0x0000000000485094 in nautilus_bookmark_constructed ()
#6  0x00007fe561c6d485 in g_object_newv (object_type=object_type@entry=12315888, n_parameters=n_parameters@entry=3, parameters=parameters@entry=0x12a8820) at gobject.c:1747
#7  0x00007fe561c6d816 in g_object_new_valist (object_type=object_type@entry=12315888, first_property_name=first_property_name@entry=0x4fffc4 "indow-slot.c:564", var_args=var_args@entry=0x7fff977d3e30) at gobject.c:1836
#8  0x00007fe561c6db91 in g_object_new (object_type=12315888, first_property_name=0x4fffc4 "indow-slot.c:564") at gobject.c:1551
#9  0x0000000000485424 in nautilus_bookmark_new ()
#10 0x0000000000478ed0 in view_begin_loading_cb ()
#11 0x00007fe561c66af8 in g_closure_invoke (closure=0x112b960, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fff977d4130, invocation_hint=invocation_hint@entry=0x7fff977d40d0)
    at gclosure.c:777
#12 0x00007fe561c781ad in signal_emit_unlocked_R (node=node@entry=0xf14b90, detail=detail@entry=0, instance=instance@entry=0x106e380, emission_return=emission_return@entry=0x0, 
    instance_and_params=instance_and_params@entry=0x7fff977d4130) at gsignal.c:3584
#13 0x00007fe561c7ff8a in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fff977d42b0) at gsignal.c:3328
#14 0x00007fe561c8023f in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3384
#15 0x00000000004687eb in finish_loading_if_all_metadata_loaded ()
#16 0x0000000000468af3 in metadata_for_directory_as_file_ready_callback ()
#17 0x00000000004a76f3 in call_ready_callbacks_at_idle ()
#18 0x00007fe561976ac6 in g_main_dispatch (context=0xb64c10) at gmain.c:3058
#19 g_main_context_dispatch (context=context@entry=0xb64c10) at gmain.c:3634
#20 0x00007fe561976e48 in g_main_context_iterate (context=context@entry=0xb64c10, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3705
#21 0x00007fe561976efc in g_main_context_iteration (context=0xb64c10, context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3766
#22 0x00007fe561f3eb84 in g_application_run (application=0xb42000, argc=<optimized out>, argv=0x7fff977d4668) at gapplication.c:1623
#23 0x000000000042a3db in main ()

Comment 9 Vladimir Benes 2015-05-14 10:34:25 UTC
Despite upstream bug saying fixed, it isn't. I can still reproduce.

connect to server:
ftp://ftp.supermicro.com/CDR-NIC_1.31_for_Add-on_NIC_Cards/Broadcom/Manuals

unmount, mount again and unmount if the crash doesn't occur before.

Comment 10 Vladimir Benes 2015-05-14 10:41:31 UTC
oh, no, another gdb crash, we have to wait till it's fixed to attach backtrace.

Comment 11 Vladimir Benes 2015-08-03 12:19:31 UTC
Created attachment 1058763 [details]
backtrace

Comment 12 Carlos Soriano 2015-11-24 18:24:26 UTC

*** This bug has been marked as a duplicate of bug 1254161 ***


Note You need to log in before you can comment on or make changes to this bug.