Bug 1254161 - Repetitive remote folder connection causes nautilus crash
Repetitive remote folder connection causes nautilus crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
: 1115338 1118266 1254203 1263236 (view as bug list)
Depends On:
Blocks: 1133060 1203710 1297830
  Show dependency treegraph
 
Reported: 2015-08-17 06:10 EDT by Martin Simon
Modified: 2016-01-29 07:41 EST (History)
9 users (show)

See Also:
Fixed In Version: nautilus-3.14.3-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:35:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream path (1.24 KB, patch)
2015-10-05 20:46 EDT, Carlos Soriano
no flags Details | Diff

  None (edit)
Description Martin Simon 2015-08-17 06:10:54 EDT
Description of problem:
After multiple connect-drop of remote location cycles, the nautilus crashes. It does not depends on the connection type. I'm really not sure if this bug is not duplicate of bz1168867 or bz1115338, because the backtrace is very similar.

Version-Release number of selected component (if applicable):
nautilus-3.14.3-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Connect any remote location (sftp,ftp,davs,smb)
2. Drop the connection
3. Connect again

Actual results:
crash

Expected results:
successful connection, no crash

Additional info:
Backtrace after crash:
ERROR:nautilus-bookmark.c:349:nautilus_bookmark_connect_file: assertion failed: (!nautilus_file_is_gone (bookmark->details->file))

Program received signal SIGABRT, Aborted.
0x00007ffff36415f7 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install libcroco-0.6.8-5.el7.x86_64 librsvg2-2.39.0-1.el7.x86_64
(gdb) bt
#0  0x00007ffff36415f7 in raise () at /lib64/libc.so.6
#1  0x00007ffff3642ce8 in abort () at /lib64/libc.so.6
#2  0x00007ffff47036d5 in g_assertion_message (domain=domain@entry=0x0, file=file@entry=0x4fb459 "nautilus-bookmark.c", line=line@entry=349, func=func@entry=0x4fbab0 <__FUNCTION__.50519> "nautilus_bookmark_connect_file", message=message@entry=0x103aaa0 "assertion failed: (!nautilus_file_is_gone (bookmark->details->file))") at gtestutils.c:2292
#3  0x00007ffff470376a in g_assertion_message_expr (domain=domain@entry=0x0, file=file@entry=0x4fb459 "nautilus-bookmark.c", line=line@entry=349, func=func@entry=0x4fbab0 <__FUNCTION__.50519> "nautilus_bookmark_connect_file", expr=expr@entry=0x4fb7a0 "!nautilus_file_is_gone (bookmark->details->file)")
    at gtestutils.c:2307
#4  0x0000000000481019 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0xb7f650 [NautilusBookmark]) at nautilus-bookmark.c:349
#5  0x0000000000481064 in nautilus_bookmark_constructed (obj=<optimized out>)
    at nautilus-bookmark.c:549
#6  0x00007ffff49e1242 in g_object_new_internal (class=class@entry=0xb70ff0, params=params@entry=0x7fffffffd640, n_params=3) at gobject.c:1814
#7  0x00007ffff49e3184 in g_object_new_valist (object_type=object_type@entry=7981888, first_property_name=first_property_name@entry=0x4f77a9 "location", var_args=var_args@entry=0x7fffffffd790) at gobject.c:2034
#8  0x00007ffff49e3581 in g_object_new (object_type=7981888, first_property_name=first_property_name@entry=0x4f77a9 "location") at gobject.c:1617
#9  0x00000000004813e4 in nautilus_bookmark_new (location=location@entry=0xb75490, custom_name=custom_name@entry=0xd15980 "") at nautilus-bookmark.c:756
#10 0x0000000000471c1d in view_begin_loading_cb (file=0xe2bd50 [NautilusVFSFile], slot=0xc92800 [NautilusWindowSlot]) at nautilus-window-slot.c:1848
#11 0x0000000000471c1d in view_begin_loading_cb (slot=0xc92800 [NautilusWindowSlot]) at nautilus-window-slot.c:2131
#12 0x0000000000471c1d in view_begin_loading_cb (slot=0xc92800 [NautilusWindowSlot]) at nautilus-window-slot.c:2409
#13 0x0000000000471c1d in view_begin_loading_cb (view=<optimized out>, slot=0xc92800 [NautilusWindowSlot]) at nautilus-window-slot.c:2264
#17 0x00007ffff49f572f in <emit signal ??? on instance 0xb96830 [NautilusCanvasView]> (instance=instance@entry=0xb96830, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3365
    #14 0x00007ffff49dbde8 in g_closure_invoke (closure=0xb20890, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fffffffda90, invocation_hint=invocation_hint@entry=0x7fffffffda30)
    at gclosure.c:768
    #15 0x00007ffff49ed70d in signal_emit_unlocked_R (node=node@entry=0xb88810, detail=detail@entry=0, instance=instance@entry=0xb96830, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffffffda90) at gsignal.c:3553
    #16 0x00007ffff49f5471 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffdc10) at gsignal.c:3309
#18 0x0000000000460bfb in finish_loading_if_all_metadata_loaded (view=0xb96830 [NautilusCanvasView]) at nautilus-view.c:9160
#19 0x0000000000460bfb in finish_loading_if_all_metadata_loaded (view=view@entry=0xb96830 [NautilusCanvasView]) at nautilus-view.c:9219
#20 0x0000000000460e13 in metadata_for_files_in_directory_ready_callback (directory=0xb761c0 [NautilusVFSDirectory], files=<optimized out>, callback_data=0xb96830) at nautilus-view.c:9260
#21 0x000000000049d702 in ready_callback_call (directory=0xb761c0 [NautilusVFSDirectory], callback=<optimized out>) at nautilus-directory-async.c:1261
#22 0x00000000004a25f3 in call_ready_callbacks_at_idle (callback_data=<optimized out>) at nautilus-directory-async.c:1798
#23 0x00007ffff46de79a in g_main_context_dispatch (context=0x792200)
    at gmain.c:3109
#24 0x00007ffff46de79a in g_main_context_dispatch (context=context@entry=0x792200) at gmain.c:3708
#25 0x00007ffff46deae8 in g_main_context_iterate (context=context@entry=0x792200, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3779
#26 0x00007ffff46deb9c in g_main_context_iteration (context=0x792200, 
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3840
#27 0x00007ffff4cc1f24 in g_application_run (application=0x76a120 [NautilusApplication], argc=argc@entry=1, argv=argv@entry=0x7fffffffdfe8)
    at gapplication.c:2282
#28 0x000000000042a0fb in main (argc=1, argv=0x7fffffffdfe8)
    at nautilus-main.c:103
Comment 1 Martin Simon 2015-09-15 08:41:31 EDT
Re-tested with nautilus nautilus-3.14.3-5.el7.x86_64 and gvfs-1.22.4-4.el7.x86_64 and the crash remains, but the backtrace has changed.

Program received signal SIGSEGV, Segmentation fault.
0x0000000000480cb1 in nautilus_bookmark_set_icon_to_default (
    bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:275
275	{
(gdb) bt
#0  0x0000000000480cb1 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:275
#1  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:364
#2  0x0000000000481240 in nautilus_bookmark_get_location (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:740
#3  0x0000000000480c8b in nautilus_bookmark_get_uri (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:751
#4  0x0000000000480d60 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:283
#5  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:364
#6  0x0000000000481240 in nautilus_bookmark_get_location (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:740
#7  0x0000000000480c8b in nautilus_bookmark_get_uri (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:751
#8  0x0000000000480d60 in nautilus_bookmark_set_icon_to_default (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:283
#9  0x0000000000481018 in nautilus_bookmark_connect_file (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:364
#10 0x0000000000481240 in nautilus_bookmark_get_location (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:740
#11 0x0000000000480c8b in nautilus_bookmark_get_uri (bookmark=bookmark@entry=0x7fffbc00a850 [NautilusBookmark]) at nautilus-bookmark.c:751
.....

Now the backtrace is similar to bug 1263236
Comment 2 Ray Strode [halfline] 2015-09-16 11:34:36 EDT
*** Bug 1263236 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Pelka 2015-10-06 04:45:21 EDT
(In reply to Carlos Soriano from comment #6)
> Created attachment 1080114 [details]
> Upstream path
> 
> The upstream fix is here:
> https://git.gnome.org/browse/nautilus/commit/?h=gnome-3-
> 14&id=a0cbf72827b87a28fba47988957001a8b4fbddf5

Carlos could you please provide fixed package or scratch build for Martin so he can test.

Thanks
 -Tom
Comment 8 Carlos Soriano 2015-10-06 08:43:44 EDT
(In reply to Tomas Pelka from comment #7)
> (In reply to Carlos Soriano from comment #6)
> > Created attachment 1080114 [details]
> > Upstream path
> > 
> > The upstream fix is here:
> > https://git.gnome.org/browse/nautilus/commit/?h=gnome-3-
> > 14&id=a0cbf72827b87a28fba47988957001a8b4fbddf5
> 
> Carlos could you please provide fixed package or scratch build for Martin so
> he can test.
> 
> Thanks
>  -Tom

Yes, when I finish fixing all the blockers I will try a scratch build.
Comment 9 Carlos Soriano 2015-10-06 11:02:03 EDT
*** Bug 1115338 has been marked as a duplicate of this bug. ***
Comment 12 Martin Simon 2015-10-07 04:08:28 EDT
I've retested this bug with nautilus-3.14.3-7.el7.x86_64 according the reproducer in comment 0 and it seems to fixed well. I've tried repetitive connection to various remote hosts (anonymous ftp, sftp, samba, davs, ssh) and repeated several times. No crash observed at all and everything worked just fine.

Marking this bug as verified.
Comment 13 errata-xmlrpc 2015-11-19 03:35:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2236.html
Comment 14 Carlos Soriano 2015-11-24 13:24:26 EST
*** Bug 1118266 has been marked as a duplicate of this bug. ***
Comment 15 Carlos Soriano 2016-01-29 07:41:13 EST
*** Bug 1254203 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.