Bug 1118272 - search command show traceback when in a debug mode
search command show traceback when in a debug mode
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 1127764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-10 06:37 EDT by Parag Nemade
Modified: 2014-09-30 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-0.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-30 06:53:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2014-07-10 06:37:36 EDT
Description of problem:
When I use command "dnf search ddnf" in debuglevel=10 then I see 2 issues in following output
------------------------------------------------------------------------------
$ dnf search ddnf
Config time: 0.006
cachedir: /var/tmp/dnf-parag-DNHGdp/x86_64/20
Loaded plugins: builddep, pkgprovides, langpacks, kickstart, noroot, Query, copr, playground, generate_completion_cache, debuginfo-install, langpacks, download, protected_packages
initialized BuildDep plugin
initialized Pkgprovides plugin
initialized Langpacks plugin
initialized Noroot plugin
Initialized Query plugin
initialized Copr plugin
initialized Playground plugin
initialized DebuginfoInstall plugin
initialized Langpacks plugin
initialized ProtectedPackages plugin
dnf version: 0.5.3
Command: dnf search ddnf 
Installroot: /
Base command: search
Extra commands: [u'ddnf']
repo: using cache for: fedora
not found deltainfo for: Fedora 20 - x86_64
repo: using cache for: local
not found deltainfo for: local for Fedora 20
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
repo: using cache for: updates
hawkey sack setup time: 0.234
Searching Packages: 
Warning: No matches found for: ddnf
Cleaning up.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 83, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1168, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/search.py", line 103, in run
    return self._search(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/search.py", line 82, in _search
    raise dnf.exceptions.Error(_('No Matches found'))
Error: No Matches found
Error: No Matches found
------------------------------------------------------------------------------


Issue1) Why both in the output warning as well as error?
Issue2) Is it expected to show traceback in debug mode?

Version-Release number of selected component (if applicable):
python3-dnf-0.5.3-1.fc20.noarch
dnf-0.5.3-1.fc20.noarch
dnf-plugins-core-0.1.1-2.fc20.noarch


How reproducible:
always


Steps to Reproduce:
1. just use command "dnf search ddnf"
2. observe the output in debug mode
Comment 1 Ales Kozumplik 2014-07-10 09:07:54 EDT
Thanks, we'll check it out.
Comment 2 Ales Kozumplik 2014-07-30 02:56:38 EDT
Parag, what is meant by 'debug mode'? I am not sure that is something we support.
Comment 3 Ales Kozumplik 2014-07-30 03:09:45 EDT
Ah, debuglevel=10, I see.
Comment 4 Ales Kozumplik 2014-07-30 06:53:12 EDT
Fixed by 57edb9f.
Comment 5 Honza Silhan 2014-08-08 04:50:33 EDT
*** Bug 1127764 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.