Bug 1118317 - Scrolling Eclipse editor is distorted
Summary: Scrolling Eclipse editor is distorted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1134295 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 12:30 UTC by Stephen Gallagher
Modified: 2015-06-05 16:06 UTC (History)
17 users (show)

Fixed In Version: eclipse-4.4.2-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-01 16:44:16 UTC


Attachments (Terms of Use)
Screencast of the distortion (2.26 MB, video/webm)
2014-07-10 12:30 UTC, Stephen Gallagher
no flags Details
Screencast AFTER the fix (3.34 MB, application/octet-stream)
2015-04-30 12:56 UTC, Nathaniel McCallum
no flags Details


Links
System ID Priority Status Summary Last Updated
Eclipse Project 463041 None None None Never

Description Stephen Gallagher 2014-07-10 12:30:55 UTC
Created attachment 917053 [details]
Screencast of the distortion

Description of problem:
When scrolling the editor window, the refresh appears to be broken. See attached screencast for an example.

I tested this with both a C and Python file, so it appears to be an Eclipse problem rather than a specific language editor.

Version-Release number of selected component (if applicable):
icu4j-eclipse-52.1-2.fc21.noarch
eclipse-gef-3.9.100-1.gitb63ec56.fc21.noarch
eclipse-emf-core-2.10.0-1.fc21.noarch
eclipse-mylyn-tasks-web-3.12.0-0.6.git20140509.fc21.noarch
eclipse-fedorapackager-0.4.1-10.fc21.noarch
eclipse-mylyn-3.12.0-0.6.git20140509.fc21.noarch
eclipse-remote-1.0.0-1.fc21.noarch
eclipse-ptp-rdt-7.0.3-1.fc20.noarch
eclipse-jdt-4.4.0-5.fc21.x86_64
eclipse-pde-4.4.0-5.fc21.x86_64
eclipse-cdt-8.4.0-1.fc21.x86_64
eclipse-oprofile-3.0.0-2.fc21.noarch
eclipse-cdt-parsers-8.4.0-1.fc21.x86_64
eclipse-valgrind-3.0.0-2.fc21.noarch
eclipse-equinox-osgi-4.4.0-5.fc21.x86_64
eclipse-emf-2.10.0-1.fc21.noarch
eclipse-dtp-1.11.2-5.fc21.noarch
eclipse-ecf-core-3.8.1-1.fc21.noarch
eclipse-rpm-editor-3.0.0-2.fc21.noarch
eclipse-packagekit-0.1.0-7.fc21.noarch
eclipse-ptp-rdt-xlc-7.0.3-1.fc20.noarch
eclipse-mylyn-tasks-bugzilla-3.12.0-0.6.git20140509.fc21.noarch
eclipse-p2-discovery-4.4.0-5.fc21.x86_64
eclipse-linuxtools-3.0.0-2.fc21.noarch
eclipse-mylyn-tasks-trac-3.12.0-0.6.git20140509.fc21.noarch
eclipse-swt-4.4.0-5.fc21.x86_64
eclipse-ptp-7.0.3-1.fc20.x86_64
eclipse-mylyn-context-cdt-3.12.0-0.6.git20140509.fc21.noarch
eclipse-subclipse-1.10.2-3.fc21.noarch
eclipse-egit-3.4.1-1.fc21.noarch
eclipse-pydev-3.5.0-4.fc21.noarch
eclipse-changelog-3.0.0-2.fc21.noarch
eclipse-rse-3.6.0-1.fc21.noarch
eclipse-collabnet-merge-4.0.0-4.fc21.noarch
eclipse-platform-4.4.0-5.fc21.x86_64
eclipse-mpc-1.2.1-0.2.git519e70b.fc21.noarch
eclipse-jgit-3.4.1-1.fc21.noarch
eclipse-mylyn-context-java-3.12.0-0.6.git20140509.fc21.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Open a code file
2. Scroll with mouse wheel or arrow keys
3.

Actual results:
Refresh issues on the editor

Expected results:
The editor should scroll normally.

Additional info:

Comment 1 Mat Booth 2014-07-11 09:13:23 UTC
Hi Stephen. Out of curiosity, does the problem go away if you edit your /etc/eclipse.ini file and change the "--launcher.GTK_version" option from 3 to 2?

Comment 2 Stephen Gallagher 2014-07-11 10:18:16 UTC
(In reply to Mat Booth from comment #1)
> Hi Stephen. Out of curiosity, does the problem go away if you edit your
> /etc/eclipse.ini file and change the "--launcher.GTK_version" option from 3
> to 2?

It does indeed.

Comment 4 Mat Booth 2014-07-16 15:35:56 UTC
We decided to stick with GTK2 for now in F21 due to the number of problems with it.

I reverted the changed that made GTK3 the default in F21, GTK3 is still enabled by default in rawhide (F22+).

This problem should be fixed in eclipse-4.4.0-7.fc21:
http://koji.fedoraproject.org/koji/buildinfo?buildID=544915

Comment 5 Nathaniel McCallum 2015-03-09 21:09:17 UTC
This issue wasn't really resolved, just worked around for F21. It still exists in Fedora 22. And the upstream Eclipse build doesn't have the same bug. Here is a video of the problem: https://www.youtube.com/watch?v=SeEDRJh56Ts

Comment 6 Ganapathi Kamath 2015-04-05 01:28:33 UTC
Since my previous post and now I don't see it, in fedora-21.
I have not on f22/rawhide so this comment does not invalidate previous comment

$ cat /etc/eclipse.ini  | grep launcher.GTK -A1
--launcher.GTK_version
3

$ rpm -qa | egrep -i "^eclipse" | egrep -i "platform|swt"
eclipse-swt-4.4.2-2.fc21.x86_64
eclipse-platform-4.4.2-2.fc21.x86_64

$ rpm -qa | egrep -i "^gtk3-3" 
gtk3-3.14.10-1.fc21.i686
gtk3-3.14.10-1.fc21.x86_64

$ uname -a
Linux sirius.localdomain 3.19.3-200.fc21.x86_64 #1 SMP Thu Mar 26 21:39:42 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Comment 7 Stephen Gallagher 2015-04-27 16:46:24 UTC
Just a reminder, this is a continuing problem in Fedora 22. Please either fix the GTK3 support for F22 Final or revert it to using GTK2 like you did for F21.

Comment 8 Mat Booth 2015-04-27 17:01:31 UTC
Thanks for the reminder Stephen, this has been fixed upstream and the fix will be backported shortly.

Comment 9 Fedora Update System 2015-04-29 06:48:00 UTC
eclipse-4.4.2-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/eclipse-4.4.2-5.fc22

Comment 10 Mat Booth 2015-04-29 14:05:05 UTC
*** Bug 1134295 has been marked as a duplicate of this bug. ***

Comment 11 Nathaniel McCallum 2015-04-29 14:20:49 UTC
So, this fix works - kind of. All the strange rendering still occurs, it just gets refreshed away when the drag is finished.

Comment 12 Mat Booth 2015-04-30 07:55:55 UTC
Hi Stephen,

Can you expand a bit more on the failure you are seeing with the update?

Can try temporarily renaming your ~/.eclipse directory before starting Eclipse to see if that kicks it into working?

Comment 13 Fedora Update System 2015-04-30 11:49:00 UTC
Package eclipse-4.4.2-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.4.2-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7277/eclipse-4.4.2-5.fc22
then log in and leave karma (feedback).

Comment 14 Nathaniel McCallum 2015-04-30 12:56:46 UTC
Created attachment 1020587 [details]
Screencast AFTER the fix

Comment 15 Nathaniel McCallum 2015-04-30 12:58:20 UTC
Mat, I think you meant to needinfo me not Stephen...

Comment 16 Stephen Gallagher 2015-04-30 13:05:40 UTC
No, he was talking to me. I gave negative karma on the Bodhi update because I couldn't start eclipse after updating to this build.

However, after having downgraded to the last stable build and then updating again, it seems to be working (albeit with the same distortion during scroll that you're reporting, Nathaniel). As with Nathaniel, the distortion immediately disappears once you stop scrolling, so it's still a marked improvement.

I need to run another test to see if I can get the startup failure to occur again. I have a suspicion on what caused it.

Comment 17 Stephen Gallagher 2015-04-30 13:11:26 UTC
OK, my failure was user-error. I saw a message on update and misinterpreted .rpmsave as .rpmnew, so I copied over my old /etc/eclipse.ini and broke things... reinstalling the correct one from the latest RPM works properly. (I had a .rpmsave because I'd previously modified the ini file to use GTK2).

I'll update my karma.

Comment 18 Nathaniel McCallum 2015-04-30 13:16:37 UTC
Stephen, thanks.

Mat, I also gave the update +1. However, I'm still concerned with the quality of the current fix. It gives a bad impression of the state of eclipse in Fedora. Can we either completely resolve this (my preference) or return to GTK2?

Comment 19 Alexander Kurtakov 2015-04-30 13:24:13 UTC
Nathaniel, we are doing our best to resolve as much as possible but there are just that many hours. As the author of the fix I know it's a workaround in reality but upstream would also see this so the bad impression is about eclipse in general not only on Fedora. Regarding returning to GTK2 it has a number of instabilities (mostly in the Browser component) which lead to crashes so it's not that viable solution either. 
Work will continue on finding better fix but for now this is the compromise that is less evil in my eyes.

Comment 20 Nathaniel McCallum 2015-04-30 14:01:15 UTC
Okay, thanks. I can agree with that. At least eclipse is usable at this point.

Comment 21 Fedora Update System 2015-05-01 16:44:16 UTC
eclipse-4.4.2-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Alexander Kurtakov 2015-05-04 11:44:53 UTC
*** Bug 1197661 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.