Bug 1197661 - eclipse's editor smudges on scrolling
Summary: eclipse's editor smudges on scrolling
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1204820 1212149 1214895 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-02 10:43 UTC by lejeczek
Modified: 2015-09-03 15:39 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-03 14:08:39 UTC


Attachments (Terms of Use)
smudged editor (148.51 KB, image/png)
2015-03-02 10:43 UTC, lejeczek
no flags Details

Description lejeczek 2015-03-02 10:43:40 UTC
Created attachment 997017 [details]
smudged editor

Description of problem:

sometimes editor gets smudged after scrolling, I have to click to get focus back to editor for the smudges to refresh and dissapear.

Version-Release number of selected component (if applicable):

eclipse-platform-4.4.1-17.fc22.x86_64
mesa-dri-drivers-10.5.0-1.20150218.fc22.x86_64
mesa-filesystem-10.5.0-1.20150218.fc22.x86_64
mesa-libEGL-10.5.0-1.20150218.fc22.i686
mesa-libEGL-10.5.0-1.20150218.fc22.x86_64
mesa-libEGL-devel-10.5.0-1.20150218.fc22.x86_64
mesa-libgbm-10.5.0-1.20150218.fc22.i686
mesa-libgbm-10.5.0-1.20150218.fc22.x86_64
mesa-libGL-10.5.0-1.20150218.fc22.i686
mesa-libGL-10.5.0-1.20150218.fc22.x86_64
mesa-libglapi-10.5.0-1.20150218.fc22.i686
mesa-libglapi-10.5.0-1.20150218.fc22.x86_64
mesa-libGL-devel-10.5.0-1.20150218.fc22.x86_64
mesa-libGLES-10.5.0-1.20150218.fc22.x86_64
mesa-libGLU-9.0.0-7.fc22.x86_64
mesa-libGLU-devel-9.0.0-7.fc22.x86_64
mesa-libOpenCL-10.5.0-1.20150218.fc22.x86_64
mesa-libwayland-egl-10.5.0-1.20150218.fc22.x86_64
mesa-libxatracker-10.5.0-1.20150218.fc22.x86_64
mesa-vdpau-drivers-10.5.0-1.20150218.fc22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nathaniel McCallum 2015-03-09 21:15:55 UTC
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1118317 ?

Comment 2 Mat Booth 2015-03-23 15:11:18 UTC
*** Bug 1204820 has been marked as a duplicate of this bug. ***

Comment 3 Adam 2015-03-23 15:28:08 UTC
Workaround:
Modify /etc/eclipse.ini
Change --launcher.GTK_version from 3 to 2.

So it appears that the problem is caused by some part of gtk3.

Likely whatever is causing the scrollbars to fade in and out, and render OVER the editor window rather than around it.

Comment 4 Mat Booth 2015-04-22 11:57:41 UTC
*** Bug 1212149 has been marked as a duplicate of this bug. ***

Comment 5 Alexander Kurtakov 2015-04-23 21:00:03 UTC
*** Bug 1214895 has been marked as a duplicate of this bug. ***

Comment 6 Alexander Kurtakov 2015-05-04 11:44:53 UTC

*** This bug has been marked as a duplicate of bug 1118317 ***

Comment 7 Fredy Neeser 2015-07-20 12:44:24 UTC
I'm still having this issue on Fedora 22, KDE Plasma 5.3.2.

My Eclipse LUNA SR2 (eclipse-platform-4.4.2-6.fc22.x86_64) had completely broken scrollbars with missing up/down arrows.

After implementing the Workaround of Comment #3, the Eclipse scrollbars look good again, and their up/down arrows are back as well.

However, editor window updating while scrolling is still broken:

Often, only part of the editor window gets updated after scrolling,
and the window corruption goes away only after clicking in the background
or some other window.

Please help -- the window corruption is extremely disturbing and makes Eclipse almost unusable.


I wonder if this is somehow related to the Plasma Widget style ...

My current setting:
  KDE System Settings > Application Style > Widget style: Breeze

Comment 8 Fredy Neeser 2015-07-20 12:58:27 UTC
Unfortunately, the problem is also present with

  KDE System Settings > Application Style > Widget style: GTK+ Style

after restarting Eclipse.

Comment 9 Fredy Neeser 2015-08-13 09:58:38 UTC
Further testing shows that the Eclipse editor window corruption/smudging after scrolling occurs only if I have both my laptop screen and an external monitor screen enabled, configured as adjacent screens in the KDE Display Configuration.  In this configuration, the problem is present regardless of whether Eclipse is placed on the laptop or external screen.  Note that the external monitor is supported via the nouveau driver -- it's a Lenovo W530 laptop with integrated Intel + discrete Nvidia graphics ("Optimus" technology).

The problem does NOT occur if I disable the external monitor and work on the laptop screen only.

Note also that Eclipse LUNA (with GKT2) on Fedora 21 (on a different system) works fine, but that system has a single monitor and uses Intel graphics only.

Any ideas how to narrow down this issue are much appreciated :-)


How to reproduce
----------------
The smudging on scroll problem can be reproduced easily by first minimizing and then un-minimizing the Eclipse application. Next, move a scrollbar vertically or horizontally, scroll via the mouse wheel, or click a scroll up/down arrow within the editor window, and only some parts of the editor window are updated, leaving it in a corrupted state until I click the background or another window.

- Note that this occurs *only* with the Eclipse editor window.
  Scrolling works as usual with the Eclipse project explorer window.
  Also, scrolling works fine in native KDE apps and in Firefox.

- Problem is present regardless of whether I use Clearlooks or Adwaita
  as my theme for GTK2 in
        KDE Desktop Settings > Application Style > GNOME Application Style

- Same problem with Eclipse LUNA SR1a (4.4.1) and Eclipse LUNA SR2 (4.4.2)


Configuration notes
-------------------
KDE Plasma 5.3.2
Qt 5.4.2
 
$ uname -r
4.1.3-201.fc22.x86_64

$ cat /etc/eclipse.ini  | grep launcher.GTK -A1
--launcher.GTK_version
2

$ rpm -qa | egrep -i "^eclipse" | egrep -i "platform|swt"
eclipse-swt-4.4.2-6.fc22.x86_64
eclipse-platform-4.4.2-6.fc22.x86_64

$ rpm -qa | egrep -i "^gtk2"
gtk2-engines-2.20.2-9.fc22.x86_64
gtk2-2.24.28-1.fc22.x86_64
gtk2-devel-2.24.28-1.fc22.x86_64
gtk2-2.24.28-1.fc22.i686

(Uninstalling gtk2-devel and gtk2-engines, as well as reinstalling gtk2 made no difference).

Comment 10 Alexander Kurtakov 2015-09-03 13:35:38 UTC
What is the status of this bug now that Eclipse 4.5 hit f22?

Comment 11 Paul Knox-Kennedy 2015-09-03 14:06:05 UTC
Seems to be fixed - an update on Apr 27 or thereabouts reverted my change to eclipse.ini (undoing the change of comment 2), and I no longer have any smudging.

Comment 12 Alexander Kurtakov 2015-09-03 14:08:39 UTC
Closing as per comment 11.

Comment 13 Fredy Neeser 2015-09-03 15:19:32 UTC
Problem is fixed in Fedora's eclipse, which is now using GTK3 -- see /etc/eclipse.ini.

Problem is not fixed in all other applications that are based on the eclipse framework, if they still use GTK2.
This is the case for a customized Eclipse LUNA environment, as well as for IBM Lotus Notes 9.0.1.  These applications worked fine in Fedora 20 and their scrolling is broken since I upgraded to Fedora 22.

It seems that the upgrade to Fedora 22 either broke GTK2 or introduced a compatibility issue between KDE Plasma 5, Eclipse's use of SWT, and GTK.

What else could I try to narrow down the issue for these apps?

As I understand, Redhat does not have the resources to address GTK2 related issues, so users of Eclipse applications that have not yet been ported to GTK3 are left in the rain ...

Comment 14 Alexander Kurtakov 2015-09-03 15:37:52 UTC
(In reply to Fredy Neeser from comment #13)
> Problem is fixed in Fedora's eclipse, which is now using GTK3 -- see
> /etc/eclipse.ini.
> 
> Problem is not fixed in all other applications that are based on the eclipse
> framework, if they still use GTK2.
> This is the case for a customized Eclipse LUNA environment, as well as for
> IBM Lotus Notes 9.0.1.  These applications worked fine in Fedora 20 and
> their scrolling is broken since I upgraded to Fedora 22.

Luna has GTK3 support too so you can try switching your additional products to use GTK3.

> 
> It seems that the upgrade to Fedora 22 either broke GTK2 or introduced a
> compatibility issue between KDE Plasma 5, Eclipse's use of SWT, and GTK.
> 
> What else could I try to narrow down the issue for these apps?

GTK 2 support is only going to become worse not better thus migrating to GTK 3 is the only path that makes sense nowadays.

> 
> As I understand, Redhat does not have the resources to address GTK2 related
> issues, so users of Eclipse applications that have not yet been ported to
> GTK3 are left in the rain ...

You're correct that we barely have the resources for the GTK 3 version but on the other side GTK3 support has been in Luna and even rudimentary one in Kepler so it's not like we haven't put significant effort into providing as smooth path as possible for even older products.


Note You need to log in before you can comment on or make changes to this bug.