This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 111838 - gstreamer-plugins src.rpm needs three missing BuildReq's
Summary: gstreamer-plugins src.rpm needs three missing BuildReq's
Status: CLOSED DUPLICATE of bug 108478
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gstreamer-plugins (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-10 19:30 UTC by Joshua Jensen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2003-12-10 19:30:27 UTC
Description of problem:

Building gstreamer-plugins on RHEL, it is apparent that the src rpm
needs these three Build requires:

nasm
libraw1394-devel
libghttp-1.0.9-7

When building without these packages, you'll get:

RPM build errors:
    File not found by glob:
/var/tmp/gstreamer-plugins-0.6.0-root/usr/lib/gstreamer-0.6/libgst1394.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.6.0-root/usr/lib/gstreamer-0.6/libgsthttpsrc.*
    File not found by glob:
/var/tmp/gstreamer-plugins-0.6.0-root/usr/lib/gstreamer-0.6/libgstqcam.*

If you trace back through the build output you'll see:

configure: WARNING: QuickCam needs nasm
configure: These plugins will not be built: qcamsrc
and
checking for raw1394_new_handle in -lraw1394... no
configure: These plugins will not be built: dv1394src
and
checking for ghttp_request_new in -lghttp... no
configure: These plugins will not be built: gsthttpsrc

... however these three plugins are supposed to be created and
packaged... hence the failure.


Version-Release number of selected component (if applicable):

gstreamer-plugins-0.6.0-14.src.rpm


How reproducible:


Steps to Reproduce:
1.  Get on RHEL box
2.  remove the above mentioned three buildreq packages
3.  rpmbuild --rebuild gstreamer-plugins-0.6.0-14.src.rpm
  
Actual results:

Package doesn't compile

Expected results:

Package should tell us that it requires those three buildreqs

Comment 1 Bill Nottingham 2004-02-23 05:03:52 UTC

*** This bug has been marked as a duplicate of 108478 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.