Bug 1118487 - Rebase openstack-keystone to 2014.1.1
Summary: Rebase openstack-keystone to 2014.1.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 5.0 (RHEL 6)
Assignee: Nathan Kinder
QA Contact: Udi
URL:
Whiteboard:
: 1118100 (view as bug list)
Depends On: 1117894
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 20:42 UTC by Scott Lewis
Modified: 2016-04-26 13:48 UTC (History)
9 users (show)

Fixed In Version: openstack-keystone-2014.1.1-1.el6ost
Doc Type: Rebase: Bug Fixes Only
Doc Text:
The openstack-keystone packages have been rebased to upstream version 2014.1.1. For more information about this version, refer to https://launchpad.net/keystone/icehouse/2014.1.1 This rebase includes several important bug fixes, including: * Previously, if a user had more than one role on a project, duplicate user resources were returned when listing users through the v2 Identity API. These duplicate user resources are now filtered out before returning the response to clients.(Launchpad#1308218) * The migration of Identity's SQL assignment data could fail with a 'db_sync_error' when upgrading from Havana to Icehouse due to charset issues. The charset settings have now been corrected, allowing data migration to succeed.(Launchpad#1320855) * LDAP attribute names were being treated as case-sensitive by the Identity service, even though the LDAP standards specify that attribute names are case-insensitive. This could cause LDAP-related operations such as authentication to fail when the LDAP server returned an attribute name in a case that Identity did not expect. The Identity service has been fixed to properly treat LDAP attribute names as case-insensitive.(Launchpad#1281216) * When using LDAP as the Identity backend, there was previously no ability to map additional attributes that are unknown to Identity. The mapping of arbitrary attributes is now allowed.(Launchpad#1293698)
Clone Of: 1117894
Environment:
Last Closed: 2014-07-28 18:57:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0957 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Identity 2014-07-28 22:56:21 UTC

Comment 2 Udi 2014-07-15 12:01:13 UTC
Passed sanity test: 
python-keystoneclient-0.9.0-1.el6ost.noarch
python-keystone-2014.1.1-1.el6ost.noarch
openstack-keystone-2014.1.1-1.el6ost.noarch

Comment 4 Nathan Kinder 2014-07-21 14:53:22 UTC
*** Bug 1118100 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2014-07-28 18:57:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0957.html


Note You need to log in before you can comment on or make changes to this bug.