Bug 111861 - Check for correct syntax before restart
Summary: Check for correct syntax before restart
Status: CLOSED DUPLICATE of bug 111860
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-10 23:43 UTC by Diego Torres Milano
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Diego Torres Milano 2003-12-10 23:43:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20021003

Description of problem:
dhcp should not be stopped when 'service dhcpd restart' was issued and
there's a syntax error in configuration file.
A systax check should be issued before stopping the server.
This prevents problems when the service is critical.



Version-Release number of selected component (if applicable):
dhcp-3.0pl2

How reproducible:
Always

Steps to Reproduce:
1.Edit dhcpd configuration file and introduce some syntax error
2.servive dhcpd restart
3.
    

Additional info:

Comment 1 Daniel Walsh 2003-12-29 11:45:21 UTC

*** This bug has been marked as a duplicate of 111860 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.