Bug 1118790 - Docker's systemd unit file should have allow passing "$DOCKER_OPTS"
Summary: Docker's systemd unit file should have allow passing "$DOCKER_OPTS"
Keywords:
Status: CLOSED DUPLICATE of bug 1119042
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: John Keck
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 14:18 UTC by Karl Hastings
Modified: 2019-03-22 07:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-15 16:39:33 UTC


Attachments (Terms of Use)

Description Karl Hastings 2014-07-11 14:18:17 UTC
Description of problem:
docker's systemd unit file should have allow users to pass options to the docker daemon through a "$DOCKER_OPTS=" line in /etc/sysconfig/docker

Version-Release number of selected component (if applicable):
docker-0.11.1-19.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to pass options to the docker daemon via '/etc/sysconfig/docker'
2. 
3.

Actual results:
Not able to

Expected results:
setting a variable like 'DOCKER_OPTS="-D=true -g=/mnt/docker" ' in /etc/sysconfig/docker should pass those items to docker on daemon startup.

Additional info:

[root@rhel7 system]# diff -u docker.service*
--- docker.service	2014-07-11 10:16:05.493437115 -0400
+++ docker.service.new	2014-07-11 10:15:53.929820456 -0400
@@ -6,7 +6,7 @@
 [Service]
 Type=notify
 EnvironmentFile=-/etc/sysconfig/docker
-ExecStart=/usr/bin/docker -d --selinux-enabled
+ExecStart=/usr/bin/docker -d --selinux-enabled $DOCKER_OPTS
 Restart=on-failure
 LimitNOFILE=1048576
 LimitNPROC=1048576

Comment 2 Daniel Walsh 2014-07-15 16:39:33 UTC

*** This bug has been marked as a duplicate of bug 1119042 ***


Note You need to log in before you can comment on or make changes to this bug.