Bug 1119042 - add other_args to docker systemd script
Summary: add other_args to docker systemd script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: John Keck
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1118790 (view as bug list)
Depends On:
Blocks: 1109938
TreeView+ depends on / blocked
 
Reported: 2014-07-13 14:02 UTC by Peng Yong
Modified: 2019-03-22 07:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 20:46:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1266 normal SHIPPED_LIVE docker bug fix and enhancement update 2014-09-19 00:45:12 UTC

Description Peng Yong 2014-07-13 14:02:41 UTC
Description of problem:

1. there is other_args of docker on EPEL 6 which missed in RHEL7 extras or EPEL7.
2. selinux-enabled arg should be customised

vi /etc/sysconfig/docker
other_args="--selinux-enabled -H tcp://0.0.0.0:4243 -H unix:///var/run/docker.sock"

vim /usr/lib/systemd/system/docker.service

[Unit]
Description=Docker Application Container Engine
Documentation=http://docs.docker.io
After=network.target

[Service]
Type=notify
EnvironmentFile=-/etc/sysconfig/docker
ExecStart=/usr/bin/docker -d $other_args
Restart=on-failure
LimitNOFILE=1048576
LimitNPROC=1048576

[Install]
WantedBy=multi-user.target

Comment 2 Daniel Walsh 2014-07-15 16:38:54 UTC
Fixed in docker-io-1.0.0-10.el7

 grep Exec.*docker /lib/systemd/system/docker.service 
ExecStart=/usr/bin/docker -d $OPTIONS

 cat /etc/sysconfig/docker 
# /etc/sysconfig/docker

# Modify these options if you want to change the way the docker daemon runs
OPTIONS=--selinux-enabled -H fd://

Comment 3 Daniel Walsh 2014-07-15 16:39:33 UTC
*** Bug 1118790 has been marked as a duplicate of this bug. ***

Comment 4 Peng Yong 2014-08-10 09:02:17 UTC
how can get latest docker rpm?

Comment 6 errata-xmlrpc 2014-09-18 20:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1266.html


Note You need to log in before you can comment on or make changes to this bug.